Wrap Behaviour Bug

  • First post - Hi everyone!

    I've read some posts from last year about problems when applying the Wrap behaviour to sprites, such as the sprite failing to be placed to the other end of the stage and instead 'jumping' on the edge. It seems to have caused some confusion for a while now.

    I have managed to pin down exactly what leads to this bug; when the origin point reaches the end of the layout before the centre of the sprite does.

    I have uploaded an example. You might notice that the Wrap will fail when moving forward over the edge of the layout, but it WILL work when going in reverse. This is because the origin point is aligned to the tip of the ship.

    ubuntuone.com/0IWHHIDa7qXZgnWaLCRiTU

    I'm going to work around it by changing the dimensions of my sprite frames so they match eachother (allowing me to simply align the origin to the centre), but it'd be nice to see this problem stamped out for good.

    Sorry for the long winded post there - I wanted to be thorough <img src="smileys/smiley2.gif" border="0" align="middle" />

  • Ah, thanks - there is indeed a problem if the origin is not centered. Should be fixed for next build.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I've already fallen madly love you guys <img src="smileys/smiley9.gif" border="0" align="middle" />

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)