No window frame in node-webkit (r190)

  • Problem Description

    When previewing a game with node-webkit, or playing a game exported with node-webkit, the window frame doesn't show. This issue appeared with Construct 2 r190. I looked at both package.json and package-preview.json files in Construct's node-webkit exporter files, and in neither of them "frame" is set to false. (In package.json you can see "frame": [[[frame]]] and I had to add "frame" to package-preview.json myself since it didn't already exist, and I have set it to "frame": true but it didn't do anything.)

    When exporting the game with node-webkit, I have checked the 'Window frame' box, but still have no window frame. I have also extracted the exported package.nw file and looked at the package.json file contained in it, and I can see "frame": true .

    Finally, I also tried uninstalling Node-webkit for Construct 2, and reinstalling it, and it didn't solve the problem.

    Attach a Capx

    Description of Capx

    Steps to Reproduce Bug

    • Preview in node-webkit
    • Or export with node-webkit

    Observed Result

    There is no window frame : no minimize, maximize nor 'x' button

    Expected Result

    Affected Browsers

    • Node-webkit: (YES)

    Operating System and Service Pack

    Windows 7

    Construct 2 Version ID

    r190

  • Same here,

    Windows Vista SP2, 64-bit.

  • Did you try reverting to an earlier version of node? 10.5 performs better than the current version anyway.

  • I've had the same issue with R192.

  • I was thinking this must be something to do with the new node 11.1.

    BUT, I tried a 64bit export from r192, and I still get a normal window with Min/Max/Exit buttons.

    Wonder what the difference is?

  • TiAm, I just reverted to Node-webkit 10.5 following your tutorial, and now it works like a charm. Maybe the developpers at Scirra should tell people to download the older version of Node-webkit-for-Construct-2 until that bug is resolved with the newer version.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I think this is a node-webkit bug fixed in v0.11.5 which we just put up at scirra.com/node-webkit. Can you confirm it's fixed there?

  • Works fine on my side, thanks! What about you, spacedoubt ?

  • Indeed! Thanks!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)