Uncaught InvalidStateError

0 favourites
  • 4 posts
  • Link to .capx file (required! If link is blocked remove the http and www parts):


    Steps to reproduce:

    1. open the project

    2. preview

    3. BUG!

    Observed result:

    I had to reinstall the OS and all the software, for unrelated reasons, and when I reinstalled construct my game stopped working. It worked before the reinstallation. Other games that come with construct DO work, though.

    When I preview the game it doesn't work and this popup appears:

    Javascript error!Uncaught InvalidStateError: An attempt was made to use an object that is not, or is no longer, usable.http://localhost:50000/preview.js, line 1217 (col 11)This is either a bug in Construct 2 or a problem in a third party plugin or behavior - please report it to the developer!

    Expected result:

    To preview!

    Browsers affected:

    Chrome: yes

    Firefox: yes

    Internet Explorer: yes

    Operating system & service pack:

    Windows 7, 64bits

    Construct 2 version:


  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • It appears to work in r160.2. Please only submit bugs in the latest version of Construct 2. Also, the project is corrupt - it prompts about missing files when opening. That may be the cause of the problem you're seeing. Closing.

  • I've tried a backup of the game that is much older and didn't work either (it used to work before). So, if the capx file already includes all the elements inside it, as a RAR file, i can't see how it would be missing files.

    I think the problem is a BUG of the soft or a configuration problem, but as other capx files work in preview I doubt about that last one.

    i can't think why a project works once, and then after reinstalling all the soft it doesn't work anymore. The files aren't damaged or anything. So, i can't really figure this out.

  • Ok, I solved this stuff.

    The rpoblem was that somehow, the C2 logo image and other pngs had dissapeared within the capx file. that alone crashed the whole thing. I never erased them so this is somehow a bug. i created a new project and replaced all the files so my work was saved.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)