UI elements disappearing after certain actions

  • Problem Description

    This just started happening after the latest update. The easiest way to duplicate my problem is either selecting the sprite font object on my Game layout and changing the size of it a bit and then all of the boxes/handles for changing the object size or angle disappear and do not come back. So then I cannot see the object I actually have selected anymore until i exit C2.

    Attach a Capx

    Removed

    Description of Capx

    Its the beginning of my game jam game.

    Steps to Reproduce Bug

    • Select Sprite Font, either change the size smaller/bigger or just copy and paste another version of the object on the same layer
    • Selection objects should disappear and won't come back

    Observed Result

    No more selection indicators or object resizing handles

    Expected Result

    For it to not do that?

    Affected Browsers

    • It's in C2

    Operating System and Service Pack

    Windows 10 latest version

    Construct 2 Version ID

    Stable version.2

  • Your example has non-standard plugins so will likely not be investigated by Ashley.

    You should try to just create a simple .capx with precise instructions to recreate the bug.

  • I have the same bug.

    I just updated to the latest r12.2 while I was working on a project.

    When I selected a sprite, all sprites and tiled background become invisible, as if the opacity is 0.

    I can still select them on the layer but can't see them.

    The only plugin I have are the standard ones and iap from cramberrygames and admob.

    I have reverted back to r12 but the problem persist. Perhaps the file saved now as corrupted parameters.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • zenox98

    I did some testing and I found that the problem comes from setting "force own texture" to yes.

    When I chose force own texture to yes, the layer in question disappear from view.

    When I click preview, the layer is visible in the browser as it should.

  • Closing as no .capx provided, please see the bug report requirements. Also please make sure your graphics drivers are up-to-date.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)