Steam version export problem

  • Link to .capx file (required!):

    cardys-game.com/test.capx

    Steps to reproduce:

    1. Open file with C2 personal Steam version in beta mode (r144)

    2. Export to HTML5

    3. c2runtime.js size is 1Ko

    1. Open file with C2 free version from Scirra Website

    2. Export to HTML5

    3. c2runtime.js size is 105Ko

    Observed result:

    c2runtime.js not correct in the Steam version.

    Expected result:

    Correct c2runtime.js in all versions

    Browsers affected:

    not relevant

    Operating system & service pack:

    Windows 8

    Construct 2 version:

    r144

    Last point : The node webkit export also does not work with my Steam version. The files are created but when I launch the game (win32), nothing happens, although I see the game process (test.exe) running in the process list.

    Can't check if the node webkit works fine with free version because it's not available.

  • Everyone seems to be having this issue. See here.

  • Thanks for the reply

    However, this problem has been going on since r139 for me.

    Whatever steam version I tried to export, it never worked :'(

    So reverting to r143 won't help me.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • The Steam and standalone versions use an identical exporter, so it is strange that they would do something different. Do you have the correct version of Java installed? Are you using the 32-bit or 64-bit version of Construct 2 each time?

  • Thanks for the reply

    For Java, here is my current build : (build 1.6.0_22-b04)

    I'm using C2 64bit (windows 8)

    I tried reverting my C2 instaleld on Steam to 139.

    After reverting, I create a new retro style project (from the list of new project) I just try to export this to Node webkit or HTML% but same bug.

    HTML5 c2runtime.js is 1Ko and the .exe just do nothing expect running in background.

    Any advices ?

  • Ok,

    So following your point, I checked my Java version.

    It appears I had 4 different version of java installed at the same time... 3 version 6 (update 25,26 and 31) and one version 7 (update 40)

    Strangely, C2 was using the old version 6, when my browser detected the 7.

    So here are all the steps I did to correct :

    • Uninstall all versions of Java
    • Download Java (Be careful here, if you use C2 64Bit, you need Java 64Bit which is not the regular download, check this page to download manually the 64Bit version of Java :

      java.com/fr/download/faq/java_win64bit.xml)[/li]

    Install Java 64

    Restart C2

    Open retro style template

    Export HTML5 and Node Webkit

    Both are working now

    On my first download of Java, I got the 32 Bit without knowing and when I tried to export, C2 showed me the message about this mistake.

    So in conclusion, I'm really thankful for your tip as this Java problem might alos be the cause of crashes for others of my games, and my C2 export finally works !

    Thanks a lot !

  • Hum, can't find the button to edit first post to change subject to [SOLVED]. Or maybe there's no need on this forum ?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)