SpriteFont text with WebGL not shown properly

  • Link to .capx file (required!):

    https://

    www dropbox com/s/p2bnlvopvmfxg03/spritefont.capx

    Steps to reproduce:

    1. Right-click instance of SpriteFont already put on Layout 1 and choose "Effects"

    2. Apply any WebGL fx

    Observed result:

    text from Spritefont instance in project layout view disappears and is shown aside, blurred and upside-down. Tried with other sprite image than the prebuilt, too.

    Expected result:

    text should be the same

    Browsers affected:

    Chrome: /

    Firefox: /

    Internet Explorer: /

    Operating system & service pack:

    Windows 8.1 64bit on any graphic card

    Construct 2 version:

    r154 Personal, bought via Steam

  • your CAPX is corrupt

  • link updated (dots missing). Thanks for replying.

  • No problem for me with all effect apply on the spritefont.

    Your graphic card driver is up to date ?

  • Can't reproduce, added warp effect and it looks fine. Please add specific reproduction steps or a .capx which reproduces the problem when run, and check your graphics card drivers are up to date.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Ok, glad to know it, I'm sorry for bothering. In this case, given the ease of the process, since maybe there isn't much more I could show (at runtime webGL fx's are applied correctly so it was just a 'cosmetic' problem on my device), I will also check it on other devices and let you know if this problem should come out again.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)