Sprite Strip Issue in r113

0 favourites
  • 10 posts
From the Asset Store
Minimal Sprite Font with Stroke for Pixel Art games.
  • I am trying to import a sprite strip, and when I right click, the menu options all appear grayed out except Thumbnail Size. However, when I click the grayed out Import Sprite Strip option, it becomes black and appears to be working as the choose file dialog pops up. But when I select a file, the program hangs for a very long time until I have to quit and restart.

    You can re-create by starting a new project, create sprite, try to import sprite sheet.

    I tried both running as administrator and not and the got same issue.

    I am using Windows 7 (in boot camp on iMac) ATI Raedon HD 4850 with 8GB RAM.

  • Okay I found this work around in the forum here:


    "if I drag the Animation Frames box higher on my screen and drag the Edit Image window off the edge of my screen, the options are no longer grayed out and work correctly. No idea why this is happening."

    So the issue is more about on screen window placement or something but still needs to be fixed

  • It seems the on screen placement does not really matter as long as the Animations frames window and Edit Image window are far enough apart. There is a proximity threshold that causes the issue.

  • I can't reproduce this on my dual-monitor Windows 8 system, which allows me to move the two very far apart. Are you sure it's not an issue with your VM? Can you reproduce the issue on other Windows computers?

  • I tried this on another Windows 7 machine and there was no issue.

    I am running Windows on my iMac using a Boot Camp install so it is not a VM, it runs as a native Windows installation.

    I will just use the work around but it seems others have had this issue as well given the forum post where the work around was suggested.

    Thanks for the help anyways.

  • This happens to me, dual monitors and Windows 8. Can't find what is exactly triggering it. But at I can confirm.

  • Also. I just realized I had the "Select" tool clicked on the sprite editor. When I unchecked it, my menu options were no longer greyed out.

  • Still can't reproduce - works fine here with Windows 8 dual monitors and the "Select" tool chosen or not chosen.

  • I just ran into this, and can confirm on Win 7 x64 bit, dual monitor. Making sure the "select" tool was not chosen as mentioned by firebelly corrected the issue

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • This bug still exists. I can confirm it.


    What the bug does:

    In the "Animation frames" window all options except "Thumbnail size" are and keep grayed out.

    How to repruduce it:

    You have to make the "Edit image" window big. If it is, the options will be grayed out if the "Edit image" window is close to the "Animation frames" window. If the "Edit image" window is not big enaugh, the options will not be grayed out, even if the windows are very close to each other.

    The bug occured by editing a 800x480 image.

    If the "Edit image" window is big...but not too big the options will be grayed out. But if you wait a few seconds after you right clicked the "Animation frames" window they wont be grayed out anymore. So I assume there must be an image (size?) calculation error or something similar.

    Oh and I use r146.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)