Sprite Fonts displays text incorrectly. [SOLVED]

  • Problem Description

    The sprite font won't display text properly.

    Won't display 0s at. Trying to write with text is a jumbled mess. Writing 1234567890 leaves you with 3456789.

    Attach a Capx

    https://drive.google.com/open?id=0ByjXO ... UdnaTFFV1E

    Description of Capx

    Capx contains my spritefont and some examples.

    Steps to Reproduce Bug

    • Try writing in another text block.

    Observed Result

    See description. Text won't correspond correctly.

    Expected Result

    Text won't correspond to text written in "text".

    Affected Browsers

    • This is an engine issue, affects all browsers.

    Operating System and Service Pack

    Don't know.

    Construct 2 Version ID

    233 64bit.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • It's your spacing.

    Check the A, then look at the L

    The A has 2 transparent 1 pixel columns after it.

    L doesn't.

  • It's your spacing.

    Check the A, then look at the L

    The A has 2 transparent 1 pixel columns after it.

    L doesn't.

    Well even so that doesnt explain why the 0 doesnt show at all?

    The only thing the spacing should do is make some letters partly cut?

  • 2 pixels, 2 rows, yes.

    If the zero doesn't show try changing wrapping from word to character.

    Might try asking about stuff like this in how do I, or general, rather than first making a bug report.

    I say that as a bug of that sort would be pretty apparent.

  • I've already tried changing the wrapping

  • Perhaps I didn't make it clear that the source texture needs two extra pixels added to its width in order to work.

  • So if I add two pixels to the width of the sprite it works?

    Then how come just typing out all the letters in the correct order works fine?

  • You mean works fine except the last one?

  • I mean just using the sprite font to write all letters and numbers in the right order works fine. Writing 1 and 2 works fine but not if you just write 1234567890.

    Why does writing it all out in the right order work, except for 0, if it needs 2 more pixels in width?

    Doesnt make sense mate

  • [EDIT]

    I see what you mean with the transparent squares after the L, it totally flew over my head.

    Fixed my issue, just needed to resize.

    Mod can feel free to move this to solved.

  • Closing as fixed as per OP's post

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)