Sprite Cut In Half and Won't Allow Changes (solved sort of)

0 favourites
  • 6 posts
From the Asset Store
Minimal Sprite Font with Stroke for Pixel Art games.
  • See bug and solution in comments!

    Problem Description

    Saved my capx and everything working fine. Opened capx a few days later and the sprite I am using for a background only showed exactly half of the image in the C2 layout screen. Checked sprite and it shows full image. Ran game and it shows full image. Tried to erase and reinsert image picture and still shows only half in C2 layout screen. Deleted entire sprite and created new sprite with same images and still only showing half of image in layout screen. Checked and no effects or behaviors on sprite and nothing I did would change how that damn sprite appeared in the layout screen.

    Other sprites all appear normal and it is not a tiled sprite just a regular sprite.

    Then noticed my tiled sprite grid is now showing major gaps that were not there when I saved the capx and it also will not allow me to change it no matter what I try.

    I had a major system crash on another capx that shut down the whole C2 and my system previously and ever since then I am seeing strange sprite behaviors when I start C2 and some features like changing the C2 load screen have stopped working completely.

    Crash report here:


    I am not a newbie and have been using C2 for years so I know if a setting or something is causing a problem and this appears to be a bug that has persisted after a crash on C2.

    If I can not get it fixed I will delete C2 and download it again and see if that fixes the problem.

    If you have had a similar experience address it in the comments please.

    Attach a Capx

    ____ Upload a Capx to this post ____

    Description of Capx

    ____ Concise description of what this CapX does ____

    Steps to Reproduce Bug

    • Step 1
    • Step 2
    • Step 3 etc.

    Observed Result

    ____ What happens? ____

    Expected Result

    ____ What do you expect to happen? ____

    Affected Browsers

    • Chrome: (YES/NO) Chrome Yes
    • FireFox: (YES/NO)
    • Internet Explorer: (YES/NO)

    Operating System and Service Pack

    Windows 10 64 bit

    Construct 2 Version ID

    239 64 bit

  • UPDATE: I uninstalled and reinstalled R239 and still same problem?

    It appears that C2 layout is considering these a tiled sprite when they are not and this is only affecting them in the layout screen not when the game runs or the sprite is viewed in the editor.

    I copied the image to a tiled sprite and it is also showing gaps and only showing the image on the left and then a gap where it should tile on the right.

    If anyone has suggestions for fixing it I am all ears as this is a huge sandbox game and I do not want to start over because of a stinking sprite that won't do what it is told to lol!

    I still believe it is a bug related to an earlier crash which would mean something in windows 10 failed and is refusing to work in C2 possibly?

  • OK I think I figured out this problem and it is a bug of sorts.

    I am using huge wallpaper images for backgrounds and when I loaded them in the editor warned me they were extremely large. So I used the size controls in the sprite editor to make them smaller and they all appeared to be working correctly in the layout and game.

    When I opened the capx the next time all of those images in that sprite had reset to the original size of the original wallpaper but the image would not stretch to fill the sprite and appeared cut in half in the layout.

    Why I don't know but when I reduced the image in the sprite to a smaller size and stretched it in the layout it went back to normal and is showing the whole image.

    So, lesson learned that if you use huge wall papers for sprites they may appear to work and show up properly in the layout but when you open that capx the next time the sprite may appear cut in half so use smaller images for backgrounds and reduce them before loading into your sprite or you will be pulling your hair out.

    So it is a bug but not a serious one and I am able to continue my work on this game whew!

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • this bug happen to me to on r242 it only appen when i open the capx on my laptop (resolution of 1333x768) and on my desktop (1920x1080) it never happen (with the same capx)

  • this bug happen to me to on r242 it only appen when i open the capx on my laptop (resolution of 1333x768) and on my desktop (1920x1080) it never happen (with the same capx)

    I had a system crash on a sprite preview before this happened and it crashed my graphics driver and screwed up webgl and canvas2D so lots of things were screwed up when this happened.

    I got those all fixed today so I can't say what caused it for sure but it was a pain in my ass for awhile.

    ADDED: It could have been a resolution problem. I created the sprites with my resolution zoomed out to work on a large canvas and when I opened the capx the next time C2 had it zoomed in and sprites were cut in half and nothing I could do would let me reset them.

  • Closing, we also can't do anything about reports like this, please see the bug report requirements.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)