Sounds not playing

  • Link to .capx file (required!):

    dl.dropboxusercontent.com/u/8856086/TouchSound/TouchSound.capx

    dl.dropboxusercontent.com/u/8856086/TouchSound/index.html

    Steps to reproduce:

    1. Play on Mac Safari

    2. Reload 2-3 times on iOS 6.1 Safari

    3.

    Observed result:

    Sounds will not play when sprites touched after reloading on iOS.

    Sounds never play on Mac Safari.

    Expected result:

    Different sound plays when any of 3 sprites on screen touched. This works fine in Chrome even after reload but not on iOS 6.1 Safari after reload.

    Browsers affected:

    Chrome: no

    Mac Safari: yes

    iOS 6.1 Safari: yes

    Operating system & service pack:

    Mac OSX 10.8.4

    Safari 6.0.5

    iOS 6.1 safari

    Construct 2 version:

        R 139

  • Further testing reveals that if you delete the media filenames from the list in the offline.appcache everything works as it should. If you leave those in the list then the iOS web app will not play the sounds anytime after the first loading and the sounds will not play if you reload in iOS Safari. Something is broken with caching the sound files. I don't if it is Construct or iOS but it is definitely broken.

    Strangely if you preview on LAN using the web server built into Construct everything works as it should. If you save this version to the home screen as a web app it works but continually downloads data from the server. What causes this when using preview on LAN? Why is the web app continually hitting the Construct web server?

    I have also found that it is very easy to completely freeze iOS if you close an iOS web app and try to re-open it immediately. Often it requires a forced hard power down of the iOS device. Safari on iOS appears to break easily and crash the whole OS.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Yes! I experience that too!

    The crhases, the app doesnt go out, I have to force restart

    The lack of sound,

    everything that you mention.

  • BTW, question: do you also experience that the app continues working but you can't Quit it?

    (by pressing the Home button in the iPad)

  • Yes. I have had the case where the app is still functioning but it will not quit. Thanks - I thought maybe I was doing something wrong.

  • Yes! The app works but refuses to quit! I'm going crazy with this bug!

  • Man, last question: Have you tried using Sine animating something in an iPad? Do you get a good framerate or do you get lag and slowness?

    Great to know you are experiencing these things too, I thought I was doing something wrong.

    Summarizing, there are 4 bugs so far:

    1.- sounds don't work

    2.- app freezes

    3.- app works but refuses to quit

    4.- app shows continually downloading icon

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)