Sounds on iOS inconsistent unless removing them...

0 favourites
  • 10 posts
From the Asset Store
75 explosion sound effects. Essential for many games, Explosions Sounds contains a mix of explosion and impact sounds.
  • I have no capx because it's useless for this one. I tested a lot for the last 2 weeks on differents iOS platforms to get my sounds working with differents capx. The bug is an "iOS" one not one linked to specific capx...

    Steps to reproduce:

    Removing the sounds files from the offline.appcache seems to correct the problem at 100% so far. I tried before this to empty Safari cache memory on iPad and iPod Touch, I tried to restart them to be sure the cache is empty and to change directory of my games too and nothing worked for a consistent continuously working sounds in my games on iOS, except this. (Removing the sounds files from the offline.appcache)

    I hope it'll help you and other people around here. It really work like a charm now wich is great!

    Thanks for the huge work on C2, great program!

    Browsers affected:

    Chrome: no

    Firefox: no

    Internet Explorer: no

    SAFARI on iOS: yes

    Operating system & service pack:


    Construct 2 version:

    R119 (latest as of this post, wich was adressing sounds issues on iOS from the blog post announcing this release)

  • try adding ?v1 to avoid JS and sound being cached.

    Not a solution, I know...

    BTW, there's no mention of sound fixes on the r119 page

  • I can't reproduce this, the Space Blaster demo works fine and plays all audio correctly even though it uses the offline cache:

    You should not remove anything from offline.appcache because it will break offline support (your game will always need an internet connection to play).

    I think the main cause is incorrectly configured servers: if you even temporarily have the wrong MIME type set for .m4a files, the appcache might be caching the wrong MIME type, even after you fix it. Changing the URL of the game ought to fix that (after you've fixed the MIME type issue). You noted already that that doesn't work - to be able to investigate further I need a .capx and full steps to reproduce.

  • sogen:

    No mention on the R119 page maybe but a sound issue was adressed between the latest stable release and the R119 one, can't remember in wich beta release exactly. Thanks for the "cache trick".


    Thanks for the reply. ...and if I say you that I had the exact same problem with your link (Space Blaster), it can't be the MIME TYPES then, Am I wrong?

    Did you try to play Space Blaster for more than one game and by hitting "Refresh" between 2 games? It was really buggy the sound on my iPod Touch 4 AND my iPad 4 even with Space Blaster, for most games the sound didn't work at all, but the first one almost always worked after emptying the Safari cache.

    Thanks for the info for the offline support, for now I prefer the game to work every time with sounds online and not at all online than having the sounds just play sometimes... :( I just removed the m4a lines from offline.appcache file, not the .ogg so at least it will work offline for non-iOS users right?

  • You're welcome.

    I have the same issue (bad sound on refresh using an iPad2).

    As a temporary solution I'm not caching JS or audio, I'll try on a different server and let you know.

    (btw the sound change was in r118)

  • DavidA13 - did the Space Blaster demo work correctly on the first load? Or is the problem exclusively to do with pressing the 'Refresh' button?

    I still can't reproduce any problem at all on an iPad 2 with iOS 6.1. I can hit refresh mid-game on the Space Blaster demo and it restarts and plays audio exactly the same again, with full polyphonic audio.

  • I still experience these issues, have they been fixed at some point during the last year?

    I had a lot of trouble with sounds on iOS while developing a game, and it seems to be a problem with the appcache and m4a files for me as well. On the first load of the game, audio is (mostly) ok, but after that I have very little but mostly no sound at all. When using the preview over LAN feature audio works just fine, but it seems that it doesn't cache files there.

    I also tried to produce the same error with the SpaceBlaster demo, and made a 2 minute recoriding here:

    Sometimes the sounds disappear just by refreshing, but I can get the error every time if I open the demo in another tab, or by closing the tab and opening the demo again.

    I found this, but don't know if it relates to this issue:

    Clearly it is a iOS bug more than it is a Construct 2 bug, but I would really like to understand why caching audio on iOS is a problem.

    (sorry about the crippled urls, but this is my first post, so I can't submit links)

  • Im experiencing the same very difficult to figure out and work around IOS bug. I may have some insight. Heres a capx demo link below.

    Using the latest stable c2 release. Tested on ipad 7.0.4 and ipad mini 7.1. Also tested in numerous ios versions/devices in emulators. Cannot replicate in emulators.

    Steps to reproduce...

    1. close safari

    2. clear cache

    3. visit

    4. touch anywhere to trigger sound and play animation of thrown object.

    5. hit the red box with the object (sprite animation) to trigger collision sound

    6. refresh and retry a few times. The impact sound eventually stops working. Throwing sound continues to work.

    Important insight :

    In testing it seemed best to setup the throwing sound to be in the 'music' folder in c2 and triggered on touch.

    The collision sound is in the 'sound' folder in c2 and triggered on object (sprite animation) collision with red box (sprite).

    It is only the sounds from the 'sound' folder that stop playing.

    So far removing the contents of the offline apache cache file seems to resolve the issue. Further testing required.

    No cache version here...

    Clearing cache a few times and possibly closing browser eventually makes it work again. Highly unpredictable.

  • I can confirm. Clearing out the offline cache file seems to have resolved numerous related issues with sounds in 'sounds' folder not playing on refresh as well as sounds which where getting called at a random # of seconds which where not triggering regardless of refresh or not.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I was experiencing a ton of sound issues and inconsistencies between the iPad and desktop where certain sounds playing on the iPad were extremely louder than other sounds. The quick fix and work around I finally came to which resolved all of my sound issues removing all sound files in the "Music" folder and placing them in the "Sounds" folder.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)