[Solved] After 175 Upgrade (from 168)

  • Problem Description

    ---------------------------

    Construct 2 Check failure

    ---------------------------

    Check failure! This is probably a bug:

    ACE table: Expression ID duplicated in ACE table

    Condition: exp_ids.find(id) == exp_ids.end()

    File: c:\c2\source\exporters\html5\..\..\common\ERAHelpers.h

    Line: 259

    Function: void __cdecl era::ACETable::AddExpression(int,int,const class std::basic_string<wchar_t,struct std::char_traits<wchar_t>,class std::allocator<wchar_t> > &,const class std::basic_string<wchar_t,struct std::char_traits<wchar_t>,class std::allocator<wchar_t> > &,const class std::basic_string<wchar_t,struct std::char_traits<wchar_t>,class std::allocator<wchar_t> > &,const class std::basic_string<wchar_t,struct std::char_traits<wchar_t>,class std::allocator<wchar_t> > &,void (__cdecl *)(const class era::StaticResult **,int,class era::StaticEvaluation *))

    Build: release 175 (64-bit) checked

    Component: HTML5 exporter

    (Last Win32 error: 0)

    You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.

    ---------------------------

    Abort Retry Ignore

    ---------------------------

    Steps to Reproduce Bug

    • Step 1 : Run C2, upon start up, the error shows up
    • Step 2 : Click Retry to continue as normal

    Operating System and Service Pack

    Windows 8.1 Pro

    Construct 2 Version ID

    175 (64 bit) 17:04:53 on Jul 10 2014

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • This is always caused by a third-party plugin - it's not a bug in C2.

    As you haven't provided any of the required information, I can only suggest you uninstall, reboot, remove the remaining C2 folder (save plugins if needed) the reinstall C2. This should give you a clean install. If not, please post more info with required .capx.

  • Hi

    Thanks for your reply.

    I did uninstall and install new version. C2 automatically did that, I suppose.

    I don't think, there is a need to provide you a capx file as the error message showed as soon as C2 run (regardless of a capx of loaded or not).

    It could be plugin problem.

    But, the error message is not user friendly.

    So, you are saying plugins working in 168 may not work in 175?

  • Hi again,

    I found a bug in one of the plugins and already fix it.

    What I'd like to suggest is, if possible, please include the plugin name that is giving the problem in the error message.

    So that, we could pin point the issue easily.

    Cheers! ^^

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)