SOLVED R111 Animation Not Playing

  • Animation Bug Capx

    This is kind of weird:

    I've assigned an animation to play when the player is moving Up and to the Right in 8-way movement. This is only to occur when the player is also holding in the "A" button to move faster.

    The animation appears but doesn't play. Its just frozen on the first frame.

    When the 3 buttons down didn't work. I changed the conditions to include holding down the Up and Right for movement and then take into account if the player is moving at a speed faster than the normal (which is triggered by holding the A). The exact same thing happened.

    I then tested it by just assigning the animation to the Up and Right keys combined. The same thing happened.

    Finally, I assigned the animation to the down button and it worked.

    I'm using Windows Vista 64-bit and I tested it on both Chrome and Firefox. Any help is appreciated. I'm a huge fan of Construct 2. The Capx is included above.

    Ben

    NeedYourDisease

  • When up, right and A are pressed then event 40 will run and set the animation to "Left", event 41 will run and set the animation to "Up" and event 43 will set it to "FastUpRight". So every tick the animation is being changed 3 times and every time it changes it plays from the beginning. So it never gets past the first frame. Basically you need an 'A is not down' condition on events 40 and 41.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Awesome. Thank you for looking into that. It was right in front of my nose and I didn't see it.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)