[Solved: NW bug] Black box fonts with Node Webkit

  • Hey, it's been a while since I've been around!

    I thought I'd get back on C2 to play with the new stuff

    This actually appeared on a previous project that used to display fonts fine

    Could actually be a bug in a new version of Node Webkit instead?

    It may be related to that,

    but I doubt I'm already exceeding texture sizes in this case?

    Problem Description

    Node webkit preview shows black bounding boxes or nothing instead of characters

    Attach a Capx

    https://drive.google.com/file/d/0B6wXdu ... sp=sharing

    Description of Capx

    Three text boxes of various sizes

    Steps to Reproduce Bug

    • Startup TEXT appears fine
    • Press A and B to change text boxes

    Observed Result

    Bigger boxes get glitches

    Expected Result

    Nice and shinny fonts

    Affected Browsers

    • Chrome: NO
    • FireFox: NO
    • Node Webkit: YES

    Operating System and Service Pack

    Win 8

    Construct 2 Version ID

    174

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Already reported: https://www.scirra.com/forum/viewtopic.php?f=152&t=108983

    But yeah, i fixed it myself and submitted it to Roger Wang in form of a pull request to fix it in NW.

    He merged the pull request and if you want it working, download the new Node Webkit version and use that,

    or just wait till the new C2 version comes with the updated NW.

    • Conti
  • Sweet :]

    I replaced my nodewebkit with the last version and it works indeed now

    Thanks mate

  • Yo, lemo - can you tell me how you did that? I want to try and see if it fixes another issue im having with my nodewebkit build not working properly on OSX..

    Thanks man.

  • [quote:1d8l1gzl]1. You download an Updated version of Node-Webkit. (Win32)

    2. You extract the files from the ZIP.

    3. Then you copy the 6 files (You don't need Credits.html) into this location: %WhereC2IsInstalled%/Construct2/exporters/html5/node-webkit/win32/

    Could be that i got the Construct 2 installation folder name wrong, since i have the Steam version it's a bit different (Not from /exporters)

    4. (...)

    5. Now you can export your project, (...) and then enjoy NW10 (...), together with Chromium 35.

    I hope that helped

    • Conti
  • Yup, like he says

  • thanks a lot - doesnt fix the issue, unfort. but this is good info.. thank you again.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)