Save/load mouse unresponsive.

0 favourites
  • 2 posts
From the Asset Store
Progress\Loading Bar. Now Load you game like a Professional.
  • Problem Description

    It seems that there is some problem involving a mix of save/load and/or group deactivation. I have been experiencing this in my game, and I was able to replicate it in a simple test. A question on the forum didn't provide an answer. It could be me making a simple mistake, but I have not been able to spot it.

    Attach a Capx


    Description of Capx

    This is a very simple capx illustrating the problem.

    Steps to Reproduce Bug

    Try this sequence:

    -Click the yellow sprite to confirm mouse is working.

    -Press save sprite (saves).

    -Press switch sprite (switches visibility between to layers, and deactivates a group containing event sheet 1).

    -Press load (loads the previous save). Loads correctly, but now mouse clicks is not registered (system is still running though). Tried touch object too, with same result.

    Affected Browsers

    • Chrome: (YES)
    • FireFox: (YES)

    No other browser tested.

    Operating System and Service Pack

    Win7 Ultimate 64 bit

    Construct 2 Version ID


  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Thanks, should be fixed in the next build. However for style reasons I would strongly advise you do not use includes in groups!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)