Running My Game

0 favourites
From the Asset Store
five golem elements Sprites Sheet.Best for enemy or villain game characters.
  • Okay so I just got construct 2 and it's really great but I have this reoccurring problem that happens when I run my very basic amateur three step game. So I control a box attached to a stick figure I made in paint. I have it set to plat former 200 speed 200 acceleration 0 deceleration 650 jump 200 gravity, solid, bound to layout, and scroll to. The layout is 3000,480 which I just put randomly so the game could be a decent size horizontally. I start on the left corner and my only option is to move right therefore I do. When I press the right arrow to go right at about 317 pixels the game takes over for some reason and teleports me to 2700 like skips the whole 300-2700 but just teleports me to the end. I have no events on this and three of the same objects distributed in the skipped zone that I don't even get to see. I ran the debugger which showed me all the statistics of the game and when I looked at the coordinates of the box when I got to 317 I'd move in super speed until 2700. If I let go at 318 It automatically moves me to 2700 at super speed. By super speed I mean it takes 3 seconds at what I have set to 200 speed to move the 2400 pixels. Same thing when I move backwards at 2700. I stop at 2699 and automatically teleported to around 120 and can see outside the bound layout until I move right. This may sound confusing as I'm just trying to be very detailed but thanks for reading this in advance.

  • Can you post a link to a capx of what you're talking about? It's almost impossible to help without being able to look at the settings and event sheets.

  • I'm sorry how do link to a capx? I'm new to this

  • Put the capx in a dropbox public folder, right click on it and select copy the public link from the popup menu. You can just past the link url long-hand into a post as you don't yet have the rep to post a full link. I'll then take a look and hopefully be able to help...

  • /sh/p5wdltp4tgmmkux/Oce9i82eV4 <-- That is after dropbox website if I did it correctly. I just read a guide on page seven of tutorials.

  • Mmmm - it gives me a 404 error. Could you post the whole url just in case I'm screwing up the first part - and can you double check that the file is inside the public folder 'cos that would also stop me gaining access? Thanks.

  • I'm sorry how do link to a capx? I'm new to this

    or you can use .

    Simple and easy.

  • HelicopterDrops

    That's a link to the exported project. You need to 'Save as a single file' from within C2. This saves your project as a .capx. Put this in the Public folder of DropBox, then post the public link to it here.

  • Oh okay let me try this

  • I also have a question... when I post my game what if someone steals my idea or something? I mean this is just a demo to see if I'd enjoy programming and learn construct2. I'm pretty amateur.

  • That's why you should always follow the guidelines when posting in this section. It should be a minimum .capx with clear instructions and steps on re-creating the bug.

    Remember. This section is for suspected bugs in the Program itself, and not for problems with understanding or programming errors from the user. There is the 'How Do I' section for those posts.

  • Actually tried to recreate this in a new project and I can't replicate what you've done.


    A new pair of eyes would be helpful.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Nothing looks like it should cause the player's acceleration to run away to infinity and then for the platform top speed to be ignored, but there you go.... It happens. I also can't reproduce it when starting a new project.

  • HelicopterDrops

    It's because of the Anchor behavior on the ground. Once that's removed, everything is as it should be.

    I have no idea why you would want to put the anchor behavior on the ground- it's certainly not needed.

  • I actually just read the post on how to post a bug sorry about that.. I also didn't realize there was a second page so I couldn't find the replies but thank you guys for helping me. It's not teleporting me anymore so I'm very grateful. It turns out the problem was the anchor behavior I put on the ground. I have no idea what anchor does. I thought it would just make sure the ground was anchored that's why I put it but lesson learned thanks for helping once again.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)