Rex's Media plugin bug. rear camera pic turns black.

  • Problem Description

    Rex media plugin has bug that turns captured rear camera images to black. The reason is plugin allows image file less that 2.5 mb only. if image file is bigger it turns it into black. This issue doesnt happen when construct 2 inbuilt user media plugin is used for camera.

    Attach a Capx

    can be tried with rex plugin sample capx

    Description of Capx

    open rex media input plugin sample capx and try to capture image from rear camera

    Steps to Reproduce Bug

      open camera try image capture from rear camera dont try front cam it will work fine.

    Observed Result

    image turns black.

    Expected Result

    sprite should we able to display correct image instead of black image

    Affected Browsers

    • Chrome: (YES)
    • FireFox: (YES)

    Operating System and Service Pack

    windows 10

    Construct 2 Version ID

    r233

  • jatin1726

    Please see Bug Report Requirements.

    The most important part relating to your post is that NO third party plugins should be submitted - it is the responsibility of the developer to fix those, in this case, Rexxrainbow.

    It is not the responsibility of Scirra to fix plugins created by other users.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Closing as we cannot accept bug reports for third-party addons. You should report issues to the addon developer.

  • Guys, I understand and respect the concern raised but I think there is no feature in construct 2 to contact developer + wanted to make aware that this bug can cause issue in their project. THanks anyways guys.

  • jatin1726

    Send pm to me, the author of that plugin, or left message in this page.

    BTW, I tested this plugin with camera only at ipad3, it worked fine in both front and rear camera. I don't have other devices to reproduce that bug.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)