Release 186 (64-bit)

  • ---------------------------

    Construct 2 Check failure

    ---------------------------

    Check failure! This is probably a bug:

    Minifier did not output a file

    Condition: FileExists(min_js)

    File: html5.cpp

    Line: 1693

    Function: void __cdecl Exporter::DoExport(class era::IProject *,class era::ILayout *,bool,struct HWND__ *,bool,bool)

    Build: release 186 (64-bit) checked

    Component: HTML5 exporter

    (Last Win32 error: 2)

    You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.

    ---------------------------

    Interrompi Riprova Ignora

    ---------------------------

    Construct 2

  • I'm getting this too with Release 185. I assume it has something to do with me installing Java 8 recently.

    EDIT:

    Uninstalled Java 8 and now it works fine.

  • I got some errors w/ java 8 too, java sux =/

  • I am also getting an error, and am running 64 bit win 7. Happens when I try to run my project, which hasn't changed since the previous build (where is worked ok).

    Update: I hit ignore repeatedly and there were about 20 more of them!

    ---------------------------

    Construct 2 Check failure

    ---------------------------

    Check failure! This is probably a bug:

    Unknown IParameter type

    Condition: false

    File: DataJSON.cpp

    Line: 2145

    Function: void __cdecl Exporter::ParameterToJSON(class std::basic_ostringstream<wchar_t,struct std::char_traits<wchar_t>,class std::allocator<wchar_t> > &,class era::IParameter *,int)

    Build: release 186 (64-bit) checked

    Component: HTML5 exporter

    (Last Win32 error: 0)

    You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.

    ---------------------------

    Abort Retry Ignore

    ---------------------------

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Yttermayn

    This is not the same error. Check the other post concerning layout running bug

  • Ok! i test to uninstall java 8.

    Thank you!

  • OK! The solution about uninstall 8.0 of java work fine!

    Thank you!

  • Closing as fixed in the next build.

  • Still happens for me on r187 I don't even have java8 installed...

  • ok I found some errors with cocoonjs and C2 r187, posted in the general forum with solutions

  • trueicecold - r187 now actually requires Java 8, so it won't work unless you update.

  • Actually, I'm using r187 with 1.7_71 without any problems...

  • trueicecold - oh, good to know, maybe it works with Java 7 after all

  • Yeah, weird that the errors I got (and solved on my post) are the same caused by Java 1.8... Go figure

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)