R79.2 and R79.3 bugs

0 favourites
  • I thought it would be good idea to list all recent release bugs in one thread, so people can check it instead of duplicating them. feel free to participate. so here goes. if someone thinks it's better off to keep each bug in its own thread, feel free to remove this one.

    1) keyboard object events (ie. key is down) still don't work after 79.2 update, this is related to some other objects / behaviors as putting simple keyboard and moving sprite doesn't seem to reproduce it. controls don't work after export to Kongregate, Scirra Arcade, Facebook. in the lan preview they work fine, so it may be something with exported HTML. Also when exporting to html5 web site - controls DO work. this is NOT related to minifyer bug below. EDIT: seems that the mouse object is causing problems: http://www.mediafire.com/?o66w073x1m6k2c9 if you export this to kongregate/arcade/facebook it won't work (A and D to move the black box left and right respectively), but if you just remove the mouse object, it works fine. the mouse object doesn't have ANY events attached to it.

    This has been corrected by Ashley's fix: http://dl.dropbox.com/u/15217362/mouse-iframefix.zip - unfortunately not on scirra arcade, but on kongregate and facebook, games should work fine now!

    2) minifyer doesn't work, it throws an error:

    Error: this.xa.hq is not extensible

    Source: c2runtime.js

    Line: 31

    this also causes sprites and some other objects not to appear in the export.

    3) Families bug still here:

    cacotigon's capx: http://dl.dropbox.com/u/62273967/famvarbug.capx

    open and try to drag an instance of sprite onto layout

    Pasted text:


    Construct 2 Check failure


    Check failure! This is probably a bug:

    No instance value for instance variable

    Condition: i != instance_values.end()

    File: Projects\InstanceVariable.cpp

    Line: 176

    Function: class std::basic_string<wchar_t,struct std::char_traits<wchar_t>,class std::allocator<wchar_t> > __thiscall InstanceVariable::GetInstanceValueStr(class ObjectInstance *) const

    Build: release 79.2 (32-bit) checked

    Component: Construct 2 IDE

    (Last Win32 error: 0)

  • Confirm the same bug ( 1 ) in Facebook.

    Confirm the same bug ( 2 )

  • Link to r79.2 family instance variable check failure:

    R79.2 Family Instance Check Failure

  • alemar did you reproduce it? wow I thought I was the only lucky one :) how did you do it? I can't seem to reproduce it from an empty project, occurs only in my old ones.

  • I did not try in a new one.but the project I'm working , have the bug.and I have a big problem because this now...

  • alemar I updated the first post, it's related to the mouse plugin somehow, if your project does't need a mouse plugin, just remove it and keyboard will work fine. anyhow, hoping for a fix, as lots of games use mouse AND keyboard :)

  • 1) I think I've traced this to the workaround for the Chrome 'sticky keys' bug. The workaround prevents iframes from getting focus which means they never get keyboard input. So I've disabled the workaround when in an iframe, which unfortunately means iframed games will still get the sticky keys bug in Chrome... but I think they've finally fixed it in the next release (Chrome 18) anyway.

    2) Gah, the new version of Closure Compiler I put in is buggy. I thought Google wouldn't release buggy versions of it. Reverted to the old one and it seems to work again...

    3) Another case of the same bug, should be fixed too.

    r79.3 on its way...

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • 1) I think I've traced this to the workaround for the Chrome 'sticky keys' bug. The workaround prevents iframes from getting focus which means they never get keyboard input. So I've disabled the workaround when in an iframe, which unfortunately means iframed games will still get the sticky keys bug in Chrome... but I think they've finally fixed it in the next release (Chrome 18) anyway.

    Ashley fyi, this problem also exists on Firefox 10.0.1 in my case. is there nothing that can be done on the construct side, we're bound to waiting for a browser update? thanks for clarifying the rest and on quick .2 fix (shouldn't it be 79.1? as 79 is 79.0 I believe :)

    edit: ah, the 79.3, installing and checking it out...

  • Ashley ok, I can confirm that minifyer and families bugs are fixed, but still the game won't work with keyboard object and mouse object together. is there any way to make it work again like in r78? maybe an option to enable/disable the sticky keys workaraound, some games must have mouse and keyboard and don't use shift or other windows sticky keys.

  • Ashley and ranma I can confirm that minifyer work now.But my game no work with keyboard or mouse in Facebook.My game work nice in my server with keyboard and mouse.any sugestions?

  • well

    I have a big problem now... my game work fine in my server.

    I change the button to enter ( it was a click before ) for "A" key to enter in the game, and "A" to back from the game over layout.

    In the game, all OK work fine with arrows.Try to kiss the girls...ehehe

    You can try Escola de Ax� here :


    When I test in Facebook ( in sandbox mode ) the mouse or keyboard don't work.Nothing.I can't enter the ingame of course.

    So, I'm not a programmer ( Thank you Ashley and all people envolved in development of Construct.Is a nice program and open new horizonts for me )

    Maybe I had made something wrong in my project, but the fact is , for me, it was

    working in realease 78 and I was just fining touch in Facebook object to realease...

    The game is about Carnaval, a big party in Brazil,that start tomorrow...

  • alemar the problem is still the same, when the game is launched in iframe (facebook, scirra arcade, kongregate) the keyboard plugin doesn't work when used with mouse plugin. when NOT in iframe (preview, exported html5 web site) these two work just fine. still waiting for the fix as the latest r79.3 didn't fix it, despite what's written in the release info:

    Games in an iframe (Scirra Arcade, Kongregate...) couldn't get keyboard input due to the workaround to the Chrome 'sticky keys' bug - the only solution is to disable the workaround in this case, so iframed games might still get sticky keys - it may be properly fixed by Google in Chrome 18 anyway.

    at least I don't know what "the only solution is to disable the workaround in this case" means, if i knew, I would disable it and it would work, right? :) so maybe the real question here is how to disable the workaround (and what IS workaround) to the chrome 'sticky keys'?

  • I deleted and turn off all my mouse plugin.( touch is ON ) but keyboard don't work either in Facebook ... so, keyboards don't work in iframes???

  • The keyboard object hasn't changed since October, so I can't imagine how the problem is there.

    The solution to the Chrome sticky keys issue was to block Chrome handling a left click - this seemed to cause problems with keyboard input, so now the HTML5 game explicitly asks to handle left clicks by itself. However since it blocks the browser action, I think it prevents the iframe running the game from ever getting focus, which means it also never gets keyboard focus so never gets keyboard events (they're probably only sent to the parent frame). I did add code that said if it's in an iframe, let the browser handle the action by itself, in theory letting it work like it did before, but that doesn't seem to have worked for you guys. I'll take another look tomorrow and see if I can get a fix out then.

    Sorry for the continuing problems but this all stems from trying to work around that annoying keyboard bug in Chrome - this should never have been an issue, but the workaround to the bug is causing more issues :-\

  • Here's a quick fix, a new runtime.js for the Mouse plugin:


    This won't affect the Arcade since it uses the original r79.3 runtime, but can you give it a quick spin on a Facebook or Kongregate game and see if it helps? Note the app cache might mean you have to refresh twice (check the browser console for app cache activity).

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)