[R77] Preview Browser Issue

0 favourites
  • 7 posts
From the Asset Store
This is a single chapter from the Construct Starter Kit Collection and the Student Workbook from the Workshop.
  • -IE, Firefox and Chrome installed on 32bit Vista

    -Chrome is the system default browser

    -Construct2 preferences tried:

              -Default preview browser: (default)

              -Default preview browser: Chrome

              -Custom browser: [pathToChrome]

    -All these settings launch the preview in Firefox for some reason.

    -Firefox is NOT already open when Contruct2 is launched.

    -Tried previewing with Chrome open, but a new Firefox window is still launched.

  • Do you talk about that

  • septeven Similar, but I can't get anything but Firefox to come up regardless of which browser is already open or not open.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Open the Windows 'Run' dialog, and type in 'chrome'. Does Chrome open? That's basically the command Construct 2 runs when you specifically choose Chrome in the preview browser. Also, what browser opens if you double-click a HTML file? That's also what Construct 2 simulates doing when choosing (default). So it sounds like your system is set up funny somehow.

  • Ashley

    Chrome does open from run and HTML files also open Chrome as expected.

    Strange indeed. I may be missing something obvious, though.

    ....aaaaaand it was a simple oversight! Call it my old age if you must!

    It was set separately in the project configuration, but I only kept trying to change it from Construct2 Preferences, not even thinking of the separate project config...

    Who feels like the idiot? THIS GUY!

  • Ha, well glad it's not a C2 bug :)

  • I didn't think I should open a new thread about this since it is directly related:

    I am using r86 (latest beta ATM)

    I have noticed that if you open a project where the browser was set different to default and the system does not have that specific browser installed, construct2 gives an error message about the missing browser BUT does not show you the preview of the project (Kind of a dead end and a joy killer!)

    Where as it should give the error message and then continue to show the preview with the default browser available on the system.

    Minor issue but had me scratching my head for an hour since I didn't know that you could set a specific browser in the project properties.

    EDIT: Oops, I have just realized that this forum section will not be checked for answers so I am creating a new thread in the bugs section.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)