[r76] PNG recompression standard is same as brute

0 favourites
  • 5 posts
From the Asset Store
12 unique hits, slashes and spells in transparent PNG sequences
  • Hi...

    My project had a lot of sprites (animations), and when I was exporting with PNG recompression Standard, it was as slow as brute recompression.

    Previous that r75 was two or three minutes, but now is half hour and don't finish yet.

    If PNG recompression is None, I don't have problem.

    I'm not sure if this is a bug, but before I didn't have this problem.


    PD: My project is a big folder, then I can't upload this.

  • That's odd because I didn't change anything relating to this in r76, does it do it every time?

  • Yes, when I choose Export Project, and the bar of "Exporting project" is loading, in the state bar appear "Recompressing xxxxx.png" (xxxx.png is every sprite that I used in animations). I was waiting for half hour then I closed Construct 2 because was very slow (Before R76 were two or three minutes).

    I repeat the process with brute PNG compression and it was as slow as standard. But in None PNG compression was very fast (Less than one minute).

    My project has more than 200 small sprites in PNG format (15 sprites in some animations)

    I make a new project with 30 sprites in an animation, and I had the same problem.


    Edit: I tried with construct 2 examples and I have this problem too.


  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Seems to be working fine here for me with your .capx: 'standard' is pretty quick, 'brute' just a little slower. Have you tried rebooting? There might be dead pngcrush processes hanging about or something. Also, during a long export, open task manager and list processes by CPU usage - which processes are using the most CPU? I'd guess pngcrush, but good to know for sure...

  • Thanks, I reinstalled Construct 2 and the problem was resolved, apparently the process pngout.exe (I don't know if this is of Construct 2) was causing the error (Task manager). Now I can export the project without problems.


Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)