R75 - nothing new i project but it gets an error

  • Hi,

    I just downloaded new version of construct2, compiled my old game (made with R74) and now I get this error:

    ---------------------------

    Construct 2 Check failure

    ---------------------------

    Check failure! This is probably a bug:

    Unknown fullscreen-in-browser setting

    Condition: false

    File: DataJSON.cpp

    Line: 324

    Function: void __thiscall Exporter::ProjectToJSON(class std::basic_ostringstream<wchar_t,struct std::char_traits<wchar_t>,class std::allocator<wchar_t> > &,class era::IProject *,class era::ILayout *)

    Build: release 75 (32-bit) checked

    Component: HTML5 exporter

    (Last Win32 error: 0)

    You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.

    ---------------------------

    Abort   Retry   Ignore   

    ---------------------------

  • Can you upload the .capx to dropbox or send it to me at ashleyjur@scirra.com?

  • Just got the same bug:

    Just loaded the .capx and tried to preview, then .......

    ---------------------------

    Construct 2 Check failure

    ---------------------------

    Check failure! This is probably a bug:

    Unknown fullscreen-in-browser setting

    Condition: false

    File: DataJSON.cpp

    Line: 324

    Function: void __thiscall Exporter::ProjectToJSON(class std::basic_ostringstream<wchar_t,struct std::char_traits<wchar_t>,class std::allocator<wchar_t> > &,class era::IProject *,class era::ILayout *)

    Build: release 75 (32-bit) checked

    Component: HTML5 exporter

    (Last Win32 error: 0)

    You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.

    ---------------------------

    Abort   Retry   Ignore   

    ---------------------------

    .capx HERE.

  • Ah, the 'Fullscreen in browser' setting changed in r65 from no/yes to off/on (crop mode)/on (scale mode). Projects from before r65 which havent touched the setting still say 'no'. Just change it to say 'off' and it will export properly. Fixed in next build, but the workaround is simple.

  • Nice - works fine. Now to try families :)

  • I got a bug but i fixed it. Basically i had a var called LayerAngle, and because of the new release having a layer angle expression, it wanted my layer angle var to return a parameter. So i changed the name of the var in R74 then it worked in R75. I presume many people are having this same problem?

  • smitchell - I am having this problem too. I'll do what you said.

  • Let me know how it goes It worked fine for me :)

  • It worked, many thanks.

  • Awesome, all works fine now :). Cheers

  • Phew. Thanks Ashley.

    Workaround worked fine!

  • I got another problem with exporting.

    Heres a screenshot:

    <img src="http://www.vaia.dk/11.jpg" border="0" />

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • That's another known bug, should be fixed in the next release!

  • Hi,

    I have a new version is construct2, as soon as the start to export the project get this error:

    <img src="http://cs305601.userapi.com/u21362907/-7/x_68701358.jpg" border="0" />

    Help!

    thanks in advance

  • AlbertAkefoul - please don't post new issues in old threads. Closing this thread.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)