[R72] PNG-Compression

  • It seems to me, that if C2 compresses picturefiles, they come out "inverted". If the compression ist set to none, evertything is fine...

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • If the scene is PNG with alpha channel and without an image, then export the project will have black boxes. On mobile devices are colored. If you export a project that does not compress PNG everything will be fine. But before this was not.

    Thank you! And sorry for my English.

    <img src="http://dl.dropbox.com/u/38677931/PNG%20BAG.png" border="0" />

  • I'm having this problem too, it seems that problem is happening only with this 3 guys?!I would appreciate if someone can help me with this.

    tks

  • I've encountered the same thing after export, the png was set as 32 bits png, it ended up all black (whereas is was just a 1 px black squared border).

  • Yes, it seems that sprites which contain transparency of other than 100% transparent have these ugly black boxes around them.

  • I'm not sure I understand and I can't reproduce this myself, it seems to work fine here. I've got a few questions:

    • can someone show me a simple before + after image? I can't seem to tell from the screenshots/descriptions what is actually happening to the images.
    • does this happen to the images in the export folder? i.e. can you open them in Windows Explorer and they look wrong there, or do they look right there and only appear wrong in the browser?
    • is this consistent across browsers? Which browsers is everyone using and which browsers does it reproduce/not reproduce in?
  • It occurs when ecporting to HTML5 and the "screwed" images are in the export/image folder. So it has nothing to do with the browser one uses...

    Before:

    <img src="http://quak.laurig.de/images/fadenkreuz-default-000.png" border="0" />

    After:

    <img src="http://quak.laurig.de/images/fadenkreuz-default-000_.png" border="0" />

  • Ashley, this happens in firefox and chrome(i?m only using these), but the problem is that the file in exported images loose his alpha info when the file has 100% transparency originally

  • It only happens to exported projects, and is not a browser issue as the images in the folder are also corrupted.

    99% sure that it is a problem due to the new PNG compression.

  • Huh, that's really weird. It doesn't do it any more in my dev version of r73... so I guess it's fixed in the next build :P

  • Hope it comes out soon :/

    Can't export my game until...

  • Well, you can, you just have to turn off PNG recompression.

  • Hope it comes out soon :/

    Can't export my game until...

    I had same problem, but it only effected one sprite(3 animations)

    I just exported the problem sprites into Paintshop Pro, removed the black areas then saved them back into the sprites animations folder.

  • I had this problem fixed it my moving the objects to a bottom layer.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)