[r66] Check failure when changing global var

  • Not getting the crash here.

    AMD Phenom II X2

    Windows 7 32-bit

    Radeon HD5670

  • I've tried uninstalling C2, clearing it out from the registry and reinstalling and still it crashes.

    Those who are having the crashes what graphics card do you have? I have a nVidia 8800 GT.

  • It's unlikely to be related to the graphics card - the event sheet view is software rendered. Only the layout view uses OpenGL and hardware acceleration.

  • Mines NVIDIA GeForce 8500 GT and i had tried to uninstall and clear registry also. But i wouldn't think the video card would have anything to do with it.

  • I didn't think so either but every little helps.

  • I tried, and got the same error, then crashed. (just same as Noga)

  • Not getting the crash either here

    Windows XP SP3; FireFox 7.0.1; ATI Radeon HD 4870

    Dual-core E5200 2.5 GhZ; 3,5 Go RAM

    Strangely enough so far, people with Nvidia had a problem, people with ATI didn't. (please if someone with an ATI encounters this problem, say it fast to discard it as a possible cause).

    There wouldn't be reasons for graphic cards to have an influence on such a function, but after all this is computing, anything can happen.

  • It could be graphic related. I get errors on both computers, both have nVidia cards.

    1. win7, 8800gt

    2. vista, 9300m

    Now I'm on the second, I've opened Space Blaster and changed Rockets variable to any number, got the same crash as before plus this new one, it says - texture leak

    edit - I clicked Abort to get this message

    <img src="http://dl.dropbox.com/u/10457408/Construct/ENG_FORUM/C2Bugs/globalbug2.png" border="0" />

  • Maybe it's important or maybe it's not, but although it crashes for me following Noga's directions, generally everything is working great.

    The interesting(?) part is that if I add a Global variable, give it a suitable name and description, it doesn't crash, but the description is NOT visible in Event view (which it should) but it does show when accessing the variable from the system parameter selection list. So it would seem that it isn't quite rendering correctly for me, and as Kyatric pointed out, I'm one of those using an Nvidia.

    In case it IS anything to do with the gfx card, I'm using the latest GeForce 285.58 driver for my card.

  • I've created two files to try explain. First works fine and second crashes when I try to change the event. It crashes even clicking in "ignore".

    WorksFine.capx

    http://dl.dropbox.com/u/47364609/WorksFine.capx

    Crash.capx

    http://dl.dropbox.com/u/47364609/Crash.capx

    It works here on the 2nd computer, but it didn't work on the 1st, yesterday when I tried it, strange.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I agree with the graphic card theory (even if it's so unlikely)

    SoldjaBoy has the bug (crash on variable change)

    I have the bug

    Kyat doesn't have the bug

    and the only thing that I have in common with Soldy is the graphic card NVidia Card

    (I'm on 64bit he is on 32bit...)

    Although Kyat use an ATI card

  • Yep I have this crash too. I made a new thread though because I'm a noobface.

    ~Sol

  • FWIW, no crash here.

    ATI Radeon HDsomethingsomething.

    Win 7 64bit.

  • Mine crashed when I tried to create an event to "add to" a global variable.. no comments added

    NVIDIA GeForce GT 220

    Win 7 64 bit.

  • yea all signs point to the graphic card, would be a heck of a coincidence if it wasnt lol. just hope this gets fixed soon because i saved my game in 66 so i cannot use 65. kinda dead in the water with what i was doing.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)