R49: not previewing in FF5

0 favourites
  • 8 posts
  • C2 r49; Windows XP SP3; FireFox 5; ATI Radeon HD 4800

    Now, with the use of r49 I can't preview the project I was working on in the earlier versions (either in http and file mode).

    Even after saving my project to a new folder in r49.

    I opened a new project, previewed it with no problem.

    I even copied the preview files (no images there by the way) from the temporary folder to a folder of my local server (wampserver 2.0) and tried them from here, the preview does not work.

    On previous versions of c2, the previewing always worked.

    This even more serious. Even on export of my project it can't appear in my browser in the final index.html :/

    Note: I renamed the project first. But even with the "original" project from r48, preview does not work.

    I'm trying to create a new project/copy objects and events there to see if it changes anything.

  • So when you export all your files and run them from disk, even then it doesn't work?

    Can you send me the files for that exported project which isn't working?

    By the way, is there any chance you're running a firewall that's blocking port 50000?

  • So when you export all your files and run them from disk, even then it doesn't work?

    It does not.

    Can you send me the files for that exported project which isn't working?

    http://www.box.net/shared/x63godxhmmfo1phk2n86

    I tried as I said to copy objects/events to a new project.

    Having all the objects copied allowed me to preview the project.

    Having the events copied ended in having no preview.

    I guess there is a bug in my code that didn't affect r48 runtime, but does affect r49. I'll try again to copy/paste events and see what part makes the preview shatter.

    EDIT: I tried, and it appears that sub-events in my startup block is the problem.

    It worked in r48 though.

    By the way, is there any chance you're running a firewall that's blocking port 50000?

    No sir.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Arg, there's a silly typo bug in r49. Here's a fixed runtime.js for Sprite - close C2, paste it over <install path>\exporters\html5\plugins\sprite\runtime.js, and restart C2. Should be fixed.

  • Testing.

    EDIT: And compliments it does work. Thank you Ash.

  • OK cool, that doesn't deserve its own release, I'll just update the r49 on the server! D'oh, thanks for reporting.

  • No problem. Thank you for doing so good on the support !

  • The r49 setup file is now updated. Kyatric, you don't need to re-download, all that's different is that runtime.js file I sent you.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)