[r254] Physics Disable Collision Bug

  • Problem Description

    Disabling collision with a certain instance disables collisions for all the instances.

    Attach a Capx

    https://www.dropbox.com/s/kr05ohwo103nj ... .capx?dl=0

    Description of Capx

    It should just disable collision with the one it collided with.

    Steps to Reproduce Bug

    • Shoot da ball by pressing mouse/touch
    • See it collide with one peggle (collision with this particular is disabled)
    • But, than Collision is disabled for all the peggles, and the ball flies through everything, which is very sad <img src="{SMILIES_PATH}/icon_e_sad.gif" alt=":(" title="Sad">(

    Observed Result

    Collisions are disabled with all the peggles, the ball flies through all the peggles <img src="{SMILIES_PATH}/icon_e_sad.gif" alt=":(" title="Sad">((

    Expected Result

    It should disable collision with just this one collided instance, ant the ball should continue to bounce nicely

    Affected Browsers

    • Chrome: (YES/NO)

    Operating System and Service Pack

    win 10

    Construct 2 Version ID

    r254

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • That's by design... Box2D collision filtering has not been incorporated.

    However, you could use my plugin (paid, link below) or there's a good version of Chipmunk physics available if you search the forums. Both have 'proper' collision filtering systems..

  • Thanks, yeah it's sort of global property :/, I will hack it by destroying the instance and replacing it instantly with another sprite just for visual feedback, I'll check your plugins though.

  • Closing as this is currently by design.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)