R200 Javascript Errors on layout restart/change

0 favourites
  • 5 posts
From the Asset Store
7 Errors
$15 USD
7 Errors is a game where you have to find the 7 mistakes before time runs out. Can you find all 7? Have fun looking.
  • Problem Description

    When restarting a layout or changing layouts a javascript error appears. This only happens on certain layouts, however each layout shares the exact same objects/event sheets.

    Attach a Capx


    Description of Capx

    There are two layouts, one where the bug appears and one where it does not. Both layouts contain a moveable sprite and a grey box which triggers a layout change. Press R to restart the layout. Move the player to the grey box to go to next layout.

    Steps to Reproduce Bug

    • Preview "Bugged Layout"
    • Press R to restart layout OR move sprite to grey box to go to next layout
    • Error pops up

    Observed Result

    Javascript Error pops up in browsers, NW.js crashes

    Expected Result

    On Press R layout should restart. On collision with grey box, next layout should load.

    On the "not bugged" layout, pressing R restarts the layout as intended.

    Affected Browsers

    • Chrome: (YES)
    • FireFox: (YES)
    • Internet Explorer: (YES)

    Operating System and Service Pack

    Win 7 Prof 64-bit Service Pack 1 (6.1, Build 7601)

    Construct 2 Version ID

    Release 200 (64-bit)

  • Yeah, tried your .capx, and the problem is reproduced here.

    C2 R200

    Win 10 TP

    All drivers up to date

  • Try your level_tm object .. offset_X and Y

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Thanks for the suggestion Gigatron. I tried to offset X and Y but the error still popped up, however you still helped me figure it out.

    The level_tm tilemap object was blank, but still on the layout. As soon as I deleted it the bug went away. I did some further testing on my original project capx and found that the bug was only appearing on layouts which had an empty tilemap object on the layout (any empty tilemap object, not just the level_tm one). As soon as I deleted the tilemap object (or drew some tiles anywhere) the bug goes away. Oddly enough when I created a new tilemap and put it into the layout (but leaving it blank) there was no bug, so it seems the bug might only pop up on projects with an existing blank tilemap object in the layout.

  • Thanks for the report, should be fixed in the next build.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)