[r182] cordova-plugins does not support plugin version

  • Problem Description

    As for GetPluginSettings cordova-plugins

    Want for that to support plugin version (for example ) like following

    "cordova-plugins": "org.apache.cordova.contacts@0.2.9",

    Consequently produce automatically in c2 the following config.xml tag (including version)

    <gap:plugin name="org.apache.cordova.contacts" version="0.2.9" />

    Attach a Capx

    ____ Upload a Capx to this post ____

    Description of Capx

    ____ Concise description of what this CapX does ____

    Steps to Reproduce Bug

    • Step 1
    • Step 2
    • Step 3 etc.

    Observed Result

    ____ What happens? ____

    Expected Result

    ____ What do you expect to happen? ____

    Affected Browsers

    • Chrome: (YES/NO)
    • FireFox: (YES/NO)
    • Internet Explorer: (YES/NO)

    Operating System and Service Pack

    ____ Your operating system and service pack ____

    Construct 2 Version ID

    R182

  • I think it's a dumb feature since it encourages plugin developers to make incompatible changes which are a pain in the ass for everyone using the plugin, and meanwhile nobody gets bug fixes or other improvements unless they opt in to them. But it was easy to add so your requested syntax will work in the next build.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Ashley

    I think the native plugin version which is used can be updated according to the c2 build version.

    (Scirra will update the version after check updated native version works, because updated native version may include critical bugs => I experience sometimes)

    Thanks very much for your support!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)