r176/177 "Preload sounds" - Project does not load (ejecta)

  • Problem Description

    I have a very complex project. With a lot of sounds.

    A few weeks ago the feature "Preload sounds" (Project Properties) was not yet available.

    So I build my own sound preload on layout start.

    Whatever ... I don't know whats the problem is. But I want report a issue.

    If the Preload Sounds property is YES, my project does not load using ejecta.

    Stops at ca. 10-11% (c2 loadingbar).

    I can't reproduce this bug with new created project. :/

    But this bug exists 100%. - Perhabs other users have the same problem.

    I want to say: Test this feature (preload sounds) again extensively.

    Attach a Capx

    Sorry, I don't want to publish my source code. And can't reproduce.

    Steps to Reproduce Bug

    No way yet. (Maybe soon.)

    Observed Result

    The load with ejecta does not work. Hangs at 10% - 11%.

    And on browser the processing time takes longer. But works.

    Operating System and Service Pack

    iOS using Ejecta

    Construct 2 Version ID

    r177 (since the feature preload sounds?)

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • why you need to preload sound ?

  • I don't need the "preloadd sounds" (Project Properties). Because on layout start, I preload all sound by playing with -x db (silent) (the preload function of sound object don't works fine). Whatever...

    Ashley: Can you publish the source code of the "preload sounds" function? How does this work?

    The fact is that this feature doesn't work with ejecta in combi with the sound object etc.

    Reproducibility (yet): 0%

  • I think I could reproduce this just using Space Blaster. Should be fixed in the next build.

  • Ok great

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)