[r173]Objects disappear when forcing layer texture

0 favourites
  • 4 posts
From the Asset Store
High quality sound effect pack, in the following categories: Dark, Mystical, Peaceful
  • Problem Description

    I'm having trouble with all objects on a layer becoming invisible when I set said layer's "force own texture" to "yes". Video here:

    Subscribe to Construct videos now

    Attach a Capx


    Description of Capx

    Demonstrates the issue described above.

    Steps to Reproduce Bug

    • Once capx loads, zoom in, or pan around. The objects initially visible will disappear.

    Observed Result

    When I first load the session, I can see the objects. When I zoom or move, they all disappear. I can still grab them and move them around -- bounding box shows up -- but the only thing that makes them visible again is turning "force own texture" to "off".

    Not shown in the video, but one time the project loaded and said layer displayed correctly even when moving/zooming. And a couple times it didn't even display on the initial load. This is all with the exact same session.

    I tried deleting all the other layers, but this still happens.

    Updated graphics drivers. Reinstalled construct. Same results.

    Expected Result

    That the editor will function normally.

    Affected Browsers

      Not Applicable.

    Operating System and Service Pack

    Win 7 x64, Service Pack 2

    Construct 2 Version ID


  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Still haven't figured this out. Tried it on an old xp machine and everything seems to work fine. On 7, I've updated my graphics drivers and re-installed c2, but no change.

    Could someone on windows 7 test the capx? Wouldn't take but two seconds...I would like to know if this is something on my end or what.

  • Can't see anything wrong on Windows 8.1. Probably a graphics card driver issue, especially if it works fine on a different system.

  • Thanks for testing it Ashley. I'm using the iGPU (HD4000) that comes with my processor (3570k). This is very common so...yeah, I'm a bit baffled.

    Anyway, I've never had trouble with display glitches in-game, so I'll just work around it for now.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)