R150 - Container is not picking

0 favourites
  • 5 posts
From the Asset Store
2D fighting template based in the game that defined the fighting games genre.
  • Link to .capx file (required!):


    Steps to reproduce:

    1. Created a function call

    2. Make a family of objects

    3. Inside each object, create their cointainers

    4. Create a object inside the function call or inside a trigger

    5. Right after, Pin the child on the pather

    Observed result:

    I was working with a similar way of doing it by giving instance variables and setting their father without the containers. But now, using containers to make the job easy on this battleship game, this issue is making impossible to pick the child without workaround.

    Expected result:

    As a child created by the container, inside the same condition where the panther is created, I expected to see child setting their position against their points and pinned in the same event, but it's missing this part.

    I did the exactly same using IDs and Variables, so, if it's not my mistake, it should be a bug.

    "While on PREVIEW, press SPACEBAR"

    I did this post before researching about the issue and reading every post in this forum possible to find with the tag "Container"

    So, this is one part of the manual where said how it should work:


    What containers do

    Placing objects in a container has the following effects:

    1 If one object in a container is created, every other object in its container is also automatically created.

    2 If one object in a container is destroyed, every other associated object in its container is also destroyed.

    3 If a condition picks one object in a container, every other associated object in its container is also picked.

    In the creation event, I picked the created object and checked if it is overlapping the child, and tried several types of combination, like doing it inside the same conditional, without indenting, and checking if outside the whole event, but inside the loop, and, without loop, it still getting the same result.

    Browsers affected:

    Chrome: yes

    Operating system & service pack: Win 8.1 / 7

    Construct 2 version: 150

  • I'm having trouble understanding what the .capx is supposed to be doing. Can you create a minimal example? It looks like you should be able to demonstrate the problem with say two objects and two events.

  • I think this is the same bug I am getting here

    I have made a minimal capx of it

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Ashley,

    I created an invisible object called ship_placement, where I want locate and pin some images over it.

    To make it easy, I did containers of these image objects, and in the same event where I created the ship_placement object, setting the images to move to the designed image point and pin there, but, it's not working.

    The same behavior, made differently, where I create the ship_placement and right after creating the images, giving them instance variables IDs, and picking these images later by their ID is working right.

    The issue here is about the containers of the ship_placement, and why they are not picked and positioned as designed?

  • Your .capx appears to produce the same result whichever set of groups I enable/disable. Can you provide an example that shows a clear difference? You should also avoid using randomness in bug report projects, since it makes it hard to reproduce the same thing over and over.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)