r148 not opening

  • Link to .capx file (required!): NONE, this is related to opening construct

    Steps to reproduce:

    1. open construct

    2. it crashes on open

    3. tried running as admin

    Observed result:

    it crashes with error message, allows me to retry, ignore, abort. Ignoring just makes it unstable and crashes a few minutes later.

    Expected result:

    should open no problem

    Browsers affected:

    none

    Operating system & service pack:

    windows 8

    Construct 2 version:

        r 148

    construct error message:

    ---------------------------

    Construct 2 Check failure

    ---------------------------

    Check failure! This is probably a bug:

    ACE table: Expression ID duplicated in ACE table

    Condition: exp_ids.find(id) == exp_ids.end()

    File: c:\c2\source\exporters\html5\..\..\common\ERAHelpers.h

    Line: 254

    Function: void __cdecl era::ACETable::AddExpression(int,int,const class std::basic_string<wchar_t,struct std::char_traits<wchar_t>,class std::allocator<wchar_t> > &,const class std::basic_string<wchar_t,struct std::char_traits<wchar_t>,class std::allocator<wchar_t> > &,const class std::basic_string<wchar_t,struct std::char_traits<wchar_t>,class std::allocator<wchar_t> > &,const class std::basic_string<wchar_t,struct std::char_traits<wchar_t>,class std::allocator<wchar_t> > &,void (__cdecl *)(const class era::StaticResult **,int,class era::StaticEvaluation *))

    Build: release 148 (64-bit) checked

    Component: HTML5 exporter

    (Last Win32 error: 0)

    You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.

    ---------------------------

    Abort   Retry   Ignore   

    ---------------------------

  • Closing as not a bug, that error message is a problem with a third party plugin. Try removing your third party plugins.

  • thank you ashley, i will see what I can figure out. the only plugin it could be is google maps. ill remove it and upgrade again.

  • So, I am still getting this error, Ashley even with updating to different constructs.

    The thing is, it works fine on my mac running virtual machine.

    I have the same plugins on both.

    Any ideas?

    When I run the driver check, it says everything is a go

  • Make sure your installation is clean.

    Uninstall C2 and reboot.

    Remove any remaining folder left after reboot for C2 (note: if you wish to keep anything, just move to a different location).

    Install either latest Stable of latest beta.

    Does it still crash?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • thanks,

    I am still getting the error.

    Once the current app contest is over I am working on I will see if I can figure it out and post back

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)