[r144] Node-webkit Refuses to Even Work

0 favourites
  • 3 posts
  • Link to .capx file (required!):


    Steps to reproduce:

    1. Open the CAPX.

    2. Build a Node-webkit export.

    3. Try running the EXE export.

    Observed result:

    The game in question does not open at all aside from running in the background and it just stays there forever. This CAPX example worked before beta r144 and now that it's opened in r144 and exported, it refuses to function.

    I don't know if this is coincidence but when I tried building this example CAPX to EXE in an old copy our actual project's node-webkit export, the old game played instead of this, almost as if Construct 2 didn't even include the game's files whatsoever.

    In our actual project, I did manage to get the EXE to work, but only after deleting every single event sheet, which is obviously not a viable option.

    Expected result:

    The game was supposed to run as an EXE.

    Browsers affected:

    Chrome: N/A

    Firefox: N/A

    Internet Explorer: N/A

    Operating system & service pack:

    This has been tested on Windows 8 64-bit, Windows XP SP2 32-bit and Windows 7 64-bit.

    Construct 2 version:

    r144 64-bit with that patch Ashley released to fix OR blocks since they didn't work without it.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I just exported your .capx to node-webkit, and it ran fine.

    Please note that I didn't use minify or png recompression.

    Using release r144.2

  • Oh yeah, it appears r144 was broken in that way. I just got notified of r144.2 and it fixed this issue. Thanks.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)