[R136] renaming spritefont . Project won't open

  • https://dl.dropboxusercontent.com/u/41218343/Spritefont%20bug.capx

    dl.dropboxusercontent.com/u/41218343/Spritefont%20bug2.capx

    http://

    Steps to reproduce:

    1. Create Spritefont.

    2. Rename Spritefont, save project as CAPX and close

    3. Open Project

    Observed result:

    The project will not open.

    "Failed to open project" error massage

    "Cannot Find Object Texture File 'SpriteFontBlue.png' in the object texture folder"......

    The first Capx shows the project before renaming the spritefont and the second shows the error massage. I can't seem to recreate this with every Spritefont. SpriteFontPink caused no problems for some reason. Only renaming the other "SpriteFontBlue" caused the message. For our game project, I can't import any spritefonts or rename them without this error message.

    Expected result:

    Open project

    Browsers affected:

    N/A

    Operating system & service pack:

    Windows 7 64bit

    Construct 2 version: R136

    In addition there seems a bug importing sprite sheets with 13 columns. The last column is ignored. We added another column with a dummy character, making it 14 columns wide and everything worked fine again. I am not sure whether this applies to all odd numbers, or just unlucky 13!    

    Thanks - Great new plugin by the way.

  • I had 2 times a renaming bug too since r136, but wasn't able to reproduce it at will. Same problem though : renaming object (with sprites), save, close, reopen. When I looked into the capx with winrar, the sprite animation had a .rename after its original name. It seems to be the same here, this is the content of the "texture" folder in your capx :

    dropbox.com/s/xsp271eboejhu14/renameBug.JPG

    After renaming the file by removing the ".rename", the capx can open again.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Guizmus Thanks that's an excellent tip. I remember a similar problem when the 9patch was first introduced. I wish I knew this back then. I had no idea you could open a capx with winrar.

  • Well, it's not only capx, try it with xlsx or docx too ;) The nomenclature made me try, it worked :D

  • I can reproduce this every time at the moment. Name in the Textures folder is always *.png.rename.

  • Thanks, good find, should be fixed in next build.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)