[r128.2] Animation Toggle Bug or User Error?

  • Link to .capx file (required!):

    dl.dropboxusercontent.com/u/11212446/toggleSwitch.capx

    Steps to reproduce:

    1. Tried Two Different Ways:

    2. Tried by creating 2 different animation checks and do a check

    3. One in the capx is the 2 different frame toggle

    Observed result:

    Can only get it to toggle once.

    Did a forum search did not see any thing in relation.

    Expected result:

    Expected a mouse click to toggle between to different checks when it does the condition..

    Scared that this is once again a user error and not a bug...

    If so sorry Ashley ...

    Browsers affected:

    Chrome: yes

    Firefox: yes

    Internet Explorer: ?

    Operating system & service pack:

    Construct 2 version:

    r128.2

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • You just need to use else:

    <img src="https://dl.dropboxusercontent.com/u/8367729/construct/pics/toggleSwitch.PNG/" border="0" />

  • So User Error... Sorry Ashley. Thank you Ramones.

    One of these days I hope to post something useful...

  • Can we do this with recent version of C2? I can't get my nesting to work this way. I can't make the set ani a sub action to the mouse click and I can't use a System Else without a prior System call!

  • GuyManDude

    Can we do this with recent version of C2? I can't get my nesting to work this way. I can't make the set ani a sub action to the mouse click and I can't use a System Else without a prior System call!

    This is a very old closed bug report.

    As it says in the sticky - you should NOT post in a closed bug report, especially as this adds nothing to the OP.

    Post questions in the 'How Do I' section.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)