[r126] - crash on add frame to sprite

0 favourites
  • 4 posts
From the Asset Store
Selection frame like in RTS games, works both on mobile and desktop devices.
  • Link to .capx file (required!):


    This is actually a test in r125. I don't have the add frame crash there, but a weird ghosting problem in the interface which builds up until I can't see the interface anymore.


    Steps to reproduce:

    1. start a new project in r126

    2. add a sprite anywhere

    3. add a new frame (crash)

    The r125 problem

    1. start a new project in r125

    2. add a sprite anywhere

    3. add a new frame

    4. close the sprite modal window

    5. Ghost image of the modal window remains in the interface. minimizing and restoring only adds to the problem.

    Observed result:

    r126 problem: crash when adding a frame to a sprite

    r125 problem: ghosting when changes in the interface occur

    Weird thing, I just reinstalled r119 and it shows the same behavior as r126. No problems with any other application I run, only Construct 2.

    Expected result:

    neither ought to happen. Never had it with r119 in my previous install.

    Browsers affected:

    Chrome: no, Construct 2 program issues

    Firefox: no, Construct 2 program issues

    Internet Explorer: no, Construct 2 program issues

    Operating system & service pack:

    Windows 7 Ultimate, 64-bit, SP1

    Ati Radeon HD 4800, Ati Catalyst 13.1 (latest) and 12.4

    Construct 2 version:

    r119, r125 and r126

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Can't reproduce any of the issues describe, and I haven't seen any similar reports from other users. Given you have display glitches I'd say this is very likely to be a graphics card driver bug. Have you checked and made sure your drivers are up to date?

  • Thanks for the reply!

    13.1 is the latest according to Catalyst Control Center. Perhaps 13.2 will fix it, I don't know.

    The thing that makes me think it's a Construct2 related problem is because none of my other applications (Adobe Cloud suite, Visual Studio Express and a whole sleuth of tiny apps ranging from notepad++ to Sisoft Sandra etc.) show problems. I don't know enough about display drivers to say anything on the topic.

    The other thing is because each version has its' own problem, like the crash after inserting a frame in r119 and r126, but not on r125, while r125 has that ghosting problem that doesn't occur in r119 or r126.

    I'm planning on buying a new card within a few months since I can't use webgl with the current one (Radeon HD4890, 3 years old now). Perhaps that solves it.

  • Thread can be closed.

    I tried the latest beta r127, and it immediately crashed when I started a new project. I tried again, and noticed that ever since the crashes started I didn't have the left bar with the properties etc. I pressed the reset dialogs button and now it doesn't crash anymore!

    I tried adding a sprite: no crash! Added a few frames: no crash! So far so good ^^ I have no idea why that fixed it or what could possibly have caused the crashes in the first place, but all's well that ends well I guess. :)

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)