[r124] Check failure appears

  • Link to .capx file (required!):

    None. The error shows up when i start C2.

    Steps to reproduce:

    1. Start C2.

    Observed result:

    Check failure appears:

    ---------------------------

    Construct 2 Check failure

    ---------------------------

    Check failure! This is probably a bug:

    ACE table: Expression ID duplicated in ACE table

    Condition: exp_ids.find(id) == exp_ids.end()

    File: c:\c2\source\exporters\html5\..\..\common\ERAHelpers.h

    Line: 254

    Function: void __cdecl era::ACETable::AddExpression(int,int,const class std::basic_string<wchar_t,struct std::char_traits<wchar_t>,class std::allocator<wchar_t> > &,const class std::basic_string<wchar_t,struct std::char_traits<wchar_t>,class std::allocator<wchar_t> > &,const class std::basic_string<wchar_t,struct std::char_traits<wchar_t>,class std::allocator<wchar_t> > &,const class std::basic_string<wchar_t,struct std::char_traits<wchar_t>,class std::allocator<wchar_t> > &,void (__cdecl *)(const class era::StaticResult **,int,class era::StaticEvaluation *))

    Build: release 124 (64-bit) checked

    Component: HTML5 exporter

    (Last Win32 error: 0)

    You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.

    ---------------------------

    Abort   Retry   Ignore   

    ---------------------------

    If i hit "Retry" or "Ignore", C2 loads and works normal.

    Expected result:

    C2 loads without check error.

    Browsers affected:

    None.

    Operating system & service pack:

    Windows 7 Ultimate, 64bit, Intel i7-2600K 3.40GHz

    Construct 2 version:

    r124

    EDIT: I've just installed r124, graphic driver is up to date, according to the graphic driver check-tool.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Please move to the closed bug section.

    Re-installed a clean version without third-party plugins, now works properly.

  • This is caused by broken third party plugins. You might want to figure out which plugin it was and tell the developer (or fix it if it's your own!)

  • Yup, spent few minutes investigating and found a bug in some old plugin. Weird how it didn't show any error on older version of Construct...

    Well, it's all good now, thanks for the quick response!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)