Project won't open in 80.2

0 favourites
  • 4 posts
From the Asset Store
With this template you can create your own archer game and customize it however you want.
  • Capx

    (I first came across this problem in r80, but it's still happening for me with r80.2)

    When I tried to open my project (I hadn't touched it in a while), it failed to open in release 80 and 80.2, and I got this error message:

    ailed to open project '\\?\C:\Users\Main Account\AppData\Local\Temp\cap3D1GOV\Chao Land.caproj':

    Error in parameter 'End index': Type mismatch: - does not work with 'string' and 'integer' (use & to build strings)

    Line 823, column 49

    In Test Map ES.xml

    The file may be invalid. Try checking the file in a text editor (projects are saved in XML format).


    Motherboard: Asus M4A87TD (USB 3.0)

    OS: Windows 7 Home Premium x64 (build 7601)

    CPU: AMD Phenom II X4 925 GHz

    RAM: Mushkin 2GB DDR3-SDRAM PC3-12800 x4 (8 GB)

    Video: Zotac GeForce GTS 250 memory

    Sound: Via HD audio

    C2 Release: 80.2

  • It's due to this fix in r80:

    ebStorage: expressions that return stored values now type-checked as returning strings. WebStorage always returned values as strings, but previously the WebStorage expressions could be used where a number was needed.

    You used a WebStorage value as a number somewhere, and it's actually a string, and since r80 the editor recognises as a string which prevents your project opening. I fixed it by wrapping the WebStorage values in int() in the XML files. Recovered project

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I have the same problem, I cant open my project anymore. Im freaking out, I cant seem to fix it, and the file its trying to open does not exists...

    BTW, I saved it in the newest version, and it happened for the first time right now..

    As I said, im on the brink of crying in frustration..

    EDIT: Was able to revert to a version from 2 hours ago, thank god for dropbox!

  • MakkaOleba, that's a different issue, look at the error messages - they're different and caused by different things.

    "Audio filename cannot be found in project" sounds like one of your audio files you've imported can no longer be found. Perhaps you deleted it from a folder based project?

    Glad you've got backups set up anyway!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)