Problems with right mouse button double clicked

0 favourites
  • 9 posts
From the Asset Store
Total customisation of the input! You can combine inputs from all peripherals. Make your game accessible for everyone!
  • Hello all,

    In a simple project i have an object with an event:

    -Mouse On Object1 Clicked=> Object1 Destroy

    It works in every combination of buttons and click/double-click except double click with right mouse button.

    There's no other event that use right mouse button or even another mouse event in the entire project.

    Could there be any bug with right mouse button double-clicks on objects?

    This running r116 on win7.

  • There's no issue for me : Example capx

    This capx works as intended.

    It's strange to double click with right button though, I guess we're more used/faster to left double click than right double click.

    Also make sure it's maybe not an issue with your mouse.

  • I posted this as a possible bug because it worked normally until this issue suddently appeared. It's strange that all mouse clicks worked except that particular combination. My mouse works fine by the way.

    My object is pinned to another object (that make the physical calculations and movements).

    I double checked my project and there's no other event that requires right click inputs of any kind. Maybe one event was cancelling the other but even with everything "toggled disable" this strange behavior still remains.

    Im working on debug data. That's why i choose that combination of buttons to destroy quickly an instance.

    It worked fine until i copy my project from Win7 to WinXp and back again at Win7. Without any change it failed with just right mouse button on double clicks.

    Pretty strange even as a bug on my side but i will keep searching for errors.

    I will post a capx if i can't get rid of this bug and no one else shows the same particular problem.

    PD: I'm a fan of your gamedevtuts+ tutorials put more for the dumb minds!

  • [Capx]


    Hello again.

    I can't get rid of this strange behavior yet.

    If I change mouse buttons being clicked, it works. Just right mouse button doesn't work.

    I stripped my project of all that seems irrelevant to the objects and events that shows this behavior.

    Don't mind ugly placement of event/subevents. It's all a testbed for physics and debug data (stripped mostly in this .capx).

    But if there's a definitive bad use of some event or a bad placement of any event, order, or action that trigger this bug or any other you spot then tell me so i don't drag it along as a bad "code habit".

    Event 6 and 7 have the click event and destroy action.

    Event 13 was my suspicious bug's trigger but i changed the button there and the bug remains.

    Also if i put an OR on event 6 to destroy the object with right OR middle mouse button nothing happends with either button.

    Any help or direction will be much appreciated.

  • Yeah right double-click only works in Firefox for me. Won't work in any other browser.

  • aah, that's why it worked before. I'm switching my project from win7 on home to winxp on my office. In the office i usually test in firefox since, somehow, chrome works like a turtle there.

    So this is really a problem outside my "code". It appears to be a chrome issue and not a C2 issue too.

    Howerver, Kyatric's example and my own previous tests with simpler events worked on chrome.

    Could be a bug only triggered by a combination of factors. I can't grasp what trigger it.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Hmm even Kyatric's simple example won't work in Chrome for me.

  • Ha indeed, my example doesn't work in Chrome either.

    Yet another strange Chrome bug apparently.

  • It works in Firefox, but not in any other browser. Our code is trivial, so it looks like most browsers just don't support double-right-clicks, probably because it's a very unusual input method! (Where have you ever seen another game or app that needed a double-right click?) So I'm closing this as won't fix - I recommend you use a different input method...

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)