Preview not flushing cache to reflect changes

0 favourites
  • 9 posts
  • Problem Description

    Hi Ashley, this is a hard one to explain and reproduce. I believe it has to do with the cache and version number and not updating/flushing cache when something updates.

    Attach a Capx

    Lol, I tried, but it is browser cache and can't be shown via capx. The minute you open in different browser it shows correct changes.

    Description of Capx

    ____ Concise description of what this CapX does ____

    Steps to Reproduce Bug

    I have had it happen a few times now

    Basically I edit something, preview edit something else preview a couple times and then suddenly a change something and those changes don't show.

    For example.

    Do something with variable and show that data in textbox/spritefont and it doesn't show work in browser.

    I added 1 to variable "onboat" on left mouse click on sprite.

    In debug no variable called "onboat" and no 1 being added.

    I made another change, something different and it obviously bumped the version and changes came through.

    I also just deleted 5 sprites different project and in preview they were still there. lol.

    The easy fix and reason why I can't provide a capx is the minute you change browsers and preview in new browser. The changes are there. When I go back to problem browser the changes are not there.

    Screen capture over 2 screens.

    The 5 red sprites have been deleted, but they still showing in I.E.


    Observed Result

    I have notice a few folks in the forums struggling with variables and it not showing the data (highscore comes to mind) even though the events/actions were correct. I believe it isn't refreshing the cache (flushing it) and showing new improvements.

    Expected Result

    Preview not showing changes, but rather outdated cache.

    Affected Browsers

    Definitely IE

    I think firefox

    I can't say for sure about chrome, but I believe it is also effected.

    Operating System and Service Pack

    Win 7 pro

    Construct 2 Version ID

    Last 2 releases that i've noticed, last beta, and now stable 173.

  • Ashley, sorry didn't spot open bug by Arima, and I can confirm that this happens 100% with Internet Explorer. So judging by other topic it is all 3 browsers.

    link to active bug topic by Arimia

  • That actually sounds like a different problem than my bug. On mine, it's not a matter of changes not showing, it's a matter of the game not running correctly - logic doesn't behave right, layer parallax is messed up, the screen is flipped - stuff like that.

    Is your problem happening during preview or after export? If it's the latter, it might be because of the appcache, which you can delete or use the browser object to check if a new version is downloading and then reload when it's finished. If it's the former, on rare occasions I've had the preview not reflect the changes too, but previewing a second time has always fixed it for me.

  • Arima, its happending in preview... and yes it messes with logic - lol, I didn't submit my game into the construct2 competition because the logic wasn't working, turns out that the changes weren't being reflected correctly, so what I thought was a random bug that broke the game, was actually the cache not being refreshed with new updates/changes.

    Its actually weird, it doesn't do it all the time - hence it took me awhile to catch on. Agree that preview a second time (used to fix) because last night those red boxes remained even on 2nd/3rd/9th time in IE. I changed browser to chrome and firefox and boxes were gone. I then changed back to IE and it they were still there.

    The boxes disappeared after a couple minutes... think cache was flushed by time passed/software/c2 but it showed changes.

    Anyways, this has happened a number of times, I originally thought it was my logic, the way I tried to do things, but it definitely isn't reflecting changes, well not immediately at least. (this is on rare occasions only, not every time)

    Took me awhile to catch on because I don't build a game in one project. I build it in modules multiple projects then add them all together at the end.

    Edit: I see you point after reading your bug report in more detail. I think this is something else, but it is also the same, or at least a blend between both bug reports.

    Bug at its core: Changes don't reflect in preview, the fact that I added a variable and it didn't show. Deleted a sprite and it remained, says it is cache issue. Perhaps ashley has more insight.

    Problem is it doesn't happen all the time, it can't be reproduced - which won't help ashley. I am just going to have to cycle browsers for preview to get latest changes.

  • The next build's HTTP server explicitly disables caching. Let me know if this helps when r174 is out.

  • Will do - thanks

  • Does this still happen in r174?

  • Ashley,

    Took 10 days off so haven't actually used r174 that much, however the few hours of work I did before taking family away had zero caching issues. So I believe the issue was resolved with r174.

    I should be full steam ahead tomorrow so will bump if I spot it again. But for now this is resolved.

    Thanks for sorting this out.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • OK, closing for now, post a new issue if anything goes wrong again with r174+.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)