Preview issue

  • There seems to be an error in the HTML produced in my project. I can no longer preview it.

    I did not use any third party plugins that I am aware of. It just started after some routine editing of objects.

    I am unclear on how to remedy.

    I deleted big hunks of my large project to reduce the capx. so the project is choppy. but the error reproduces.

    Link to .capx file (required!):

    dl.dropboxusercontent.com/u/36204053/Won%27t%20preview.capx

    Steps to reproduce:

    1. open capx, hit preview.

    2. CNTRL-SHIFT-J in browser produces same errors, I am unclear how they occurred or how to remedy.

    3.

    Observed result:

    Error messages. screen shots below.   run the capx, you should get the same and have no need to look at these.

    dl.dropboxusercontent.com/u/36204053/errors.jpg

    dl.dropboxusercontent.com/u/36204053/errorS2.jpg

    Expected result:

    Able to preview

    Browsers affected:

    Chrome: yes

    Firefox: yes

    Internet Explorer: yes

    Operating system & service pack:

    Win 7 ultimate SP1

    Construct 2 version:

    146, 64 bit

  • The only errors I get are missing animation frames.

    You can extract the .capx, and simply copy and paste a few times the missing animation frames, eg navigate to PoppupHeadTitle/Default and copy frame 012.png and paste a few times. Rename as 013,014,015,016.png.

    The first Layout your projecy is set to use is Splash, but in this .capx, both the Layout and Event sheet for Splash are empty, so nothing will happen.

  • THANKS!   I'll tinker with that.

    I found that Popuphead issue but did not know what it meant.

    The Capx was chopped down per instruction.   I see your point about it not running.   I presume the full copy will run after i fix the errors.

  • It worked!!!!!

    I presume this may seem remarkably simple to some. But it's still Latin to the non programmer. Also hindered by the animation editor crashing on my PC, forcing me to pop open a separate computer to edit images.

    THANKS Zenox98!!!

    I am unclear how there were blank animations created. But it was one of the last things I edited before the issue.    So, in replacing frames, there were empty dead ones left over? With no data at all?

    Maybe a pop-up alert stating "your program won't run, you have data-less frames" might help.

    Either way...I have new skills now.

    TY

  • Squirrely1

    Glad everything worked out.

    Remember to use the Auto save/backup options in Preferences - they may save your project if this happens again, but I still recommend saving often anyway.

    I press save before every preview, and when I'm finished for the day, I save a dated .capx in a backup folder.

    After working in I.T. for over 15 years, I know the benefits of taking control of a situation and not relying on anyone or anything but yourself. I have NEVER lost any work :)

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Closing as won't fix. The .capx file is simply missing some animation frame files. We want to fix this is a bug caused them to go missing, but we can't fix it without the steps that caused the problem in the first place.

  • I think the steps may have been That I I did some pasting of new frames into an animation. Maybe there was a # mismatch and it left the remaining frames #'s, devoid of data.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)