Possible bugs on External Image Editor

0 favourites
  • 9 posts
From the Asset Store
Supports 1D, 2D, 3D arrays. Import and export arrays in JSON format
  • Image not showing on C2 image editor after saving in the external image editor

    ____Tried to import a png simple image from Photoshop cs6 (64 bits) to C2 but nothing showed up ____

    Steps to Reproduce Bug

    • Create a sprite object in c2
    • In C2's Image Editor i clicked the button to open the external image editor (opened fine).
    • Drawn a simple circle red filled and saved as a png (tried jpg) always as a 32x32 pixels size.
    • Clicked the confirmation button on C2 image editor as requested but nothing showed up. * Tried then the same but using Ms Paint (windows 7 64 bits) and worked all fine. * Ms Paint failed wasn't recognized if i use "%windir%\system32\mspaint.exe" as the path. Worked with "C:\Windows\System32\mspaint.exe". This is not part of the bug with Photoshop but keep an eye to it anyway. "%windir%" is generated by windows when you see the properties of the Ms Paint Icon.

    Observed Result

    ____ Image edited in external image editor didn't shown up ____

    Expected Result

    ____ The same behaviour as with Ms Paint or any other working image editor____

    Operating System and Service Pack

    ____ Windows 7 64 bits ____

    Construct 2 Version ID

    ____ Beta r193 ____

  • I haven't got photoshop, but I tested using Corel PSP X7 and followed your steps, it worked OK.

    I also tried editing a previously created sprite and that worked OK also.

    Not sure it helps, but it may point to the way the external program is referenced in Preferences, as you point out.

  • I double checked paths and files/directory permissions (allowed all for all users) but still fails. Only Photshop, worked with other editors.

    I'm still testing different ways to save images and internal settings like rasterizing, alphas, bits, and blabla.

    Could be a local problem in my machine but just in case i leave this issue for revision.

  • Are you sure you are saving over the existing file? The way the feature works is you save over the same .png file that is opened (which exists somewhere in a temp folder) and then it re-loads the same file again to get the changes. Normally this just means pressing the save button. If Photoshop is saving to a different file somewhere else then C2 won't pick up the changes because the original file was not modified. The fact it works with other apps suggests the C2 feature is working and Photoshop is perhaps saving to some other folder maybe?

  • Yes, i saved it in different formats (png and jpg actually) in the temp directory where Photoshop save files by default. I tried in two machines and didn't work on either. However other programs like MS Paint works fine. To me is a problem of permissions. Happened before were you suddently can't drag n' drop images directly to a program's canvas. And in that case the problem is program's damn permissions changing or not executing as admin.

    I tried all common workarounds in case those were the problems but still doesn't works. If i'm the only case with a Photoshop not working then it's not a bug.

    I will eventually make it works, don't mind Ashly.

    If you know of something please pm me

    See you Ashly and team!

  • Hillstrom - works just fine here. If your actions are just like you said - open the sprite, add a circle, that means Photoshop made a layer and thus would save as PSD per default, instead of the PNG that C2 sends its way - are you sure that wasn't the case?

    Tested on a system same as yours - W7, 64bit with Photoshop CS6 (64bit).

  • I saved in png and jpg (tried a variety of configurations like 8 bit, 16 bits, etc). My path is default: C:\Program Files\Adobe\Adobe Photoshop CS6 (64 Bit)\Photoshop.exe

    Oh oh oh.,... (while writing i was testing some more), if i check Photoshop.exe to be executed as admin it works. I don't know why so much admin rights for an already admin account with admin privileges... I swear the whole privilege system in windows if broken damn grrr....

    Anyway... solved! Remember to check the option to execute Photoshop as admin in properties. Even if you kidnapped Bill Gates and shown him your 32 ways to grant admin privilege to every f... directory and file.

    Rage aside, thanks for your support. Consider this matter solved.

    See you all!

  • Are you running Construct 2 as administrator for preview-over-wifi? That might explain it. If not, I don't see why Photoshop would need admin permission to write to a temp file. Maybe something specific to your system?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Mmm... I didn't C2 admin rights after installing the new release. But it worked with Photoshop with "Run as administrator" check in Photoshop.exe's properties.

    I tried with C2 with "run as administrator" checked in it exe's properties and Photoshop.exe unchecked and also works.

    However i tried the "run as administrator" from the right click menu and it didn't work. Only the exe's Properties "Run as administrator" seems to work. I have both directories (C2 and Photoshop) with "full control" permission enabled and still failed for photoshop but worked fine with MS Paint in any case.

    So in conclusion:

    If C2 or Photoshop's exe runs as admin it works. If none is checked as admin then could or couldn't work. Even if full permissions are enabled for both main directories.

    In the end C2 should have the admin rights more than Photoshop as i understand it.


    Marry Bill Gates and MAYBE you will eventually have admin rights as you should in an admin account with full permissions enabled everywhere. Could be a UAC problem, but as stated above it works fine now.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)