Plugins/Behaviors; After Reinstall I can't use them (solved)

0 favourites
  • 3 posts
  • Hello,

    After a complete reset with my Win7x86 OS I am now unable to use my C2Personal with any added plugins or behaviors. Originally I tried to move the entire steam folder to a flash drive and then back to my program files folder after reinstalling the OS. However now even though I can launch C2 and use it just fine all my extensions are now no longer visible to the program.

    For example I use a lot of Rexrainbows plugins in my games and he provided a app that auto installs his extensions to the necessary folders. But when I launch and try to open my capx a error pops up and says that I need to reinstall a number of plugins to get the game to launch. The same is true when I manually install a plugin.

    Also when I create a new project and try to add a object they will not show up in that menu.

    To try to fix this I have; Reinstalled C2 though Steam, Verified Integrity though Steam, Rebooted before reinstalling C2, Logged out and back into Steam, Complete reinstall of Steam.

    I am currently using Windows 7 Basic x86 SP1

    Strangely it is saying that I am running release 200 x64 bit could that be a issue? Certainly having just reinstalled though steam it should be the latest release?

    One last thing if i try to run C2 form withing my steamapps folder it wants to install C2 Free. Now I originally installed the free version to test C2 but that was more than a year ago so I should not come up like that and instead should launch C2 Personal. And yes C2Personal is what is installed.

    I cant really provided a capx as it is C2 its self that is the issue.

    Thank you for your time in reading and replying to this


  • OK so above where I mentioned that though my computer is x86 but C2 is version 200x64, somehow. After installing my plugins to my Construct 2 x64 folder path it works just fine. Strange Did not know I could even do that.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Closing as not a bug, sounds like you just erased the plugins folder and needed to reinstall them.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)