Pathfinding Broken on New Layout?

  • Link to .capx file (required!):

    Use Pathfinding Demo that comes with Construct 2 (same issue occurs with my game that I've built off of the pathfinding demo).

    Steps to reproduce:

    1. Launch the Pathfinding Demo that you provide with Construct 2.

    2. Duplicate Layout 1, creating Layout 2.

    3. Create text object on Layout 1 and set that when clicked/touched the player goes to Layout 2.

    4. Layout 2 launches successfully but the pathfinding no longer works.

    Observed result:

    I've tried using "regenerate obstacle map" (grasping at straws) but that doesn't work.

    If you launch Layout 2 directly it runs fine (as does with my game I'm building off of the demo). If you reverse things and navigate from Layout 2 to Layout 1 the pathfinding breaks as well. It is only when a previous "pathfinding" layout has been loaded that this issue occurs.

    This issue does NOT exist in Chrome. It does occur in IE and Firefox. I need this to work for an audience that will primarily use IE.

    Expected result:

    Pathfinding should continue to work?

    Browsers affected:

    Chrome: no

    Firefox: yes

    Internet Explorer: yes

    Operating system & service pack:

    Windows 7 Pro, SP 2

    Construct 2 version:

    126

  • Sounds like a duplicate of http://www.scirra.com/forum/pathfinding-bug_topic64843_page1.html. Should be fixed in the next build.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Thanks Ashley. Looking forward to the update.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)