Open project and File > Open cause Construct 2 to crash

  • Problem Description

    When going to "Open Project" from the start page or File > Open Construct 2 crashes with a "has stopped working" message. Here is a small excerpt from the event logs.

    Faulting application name: Construct2.exe, version: 2.0.0.0, time stamp: 0x53f394a1
    Faulting module name: SHELL32.dll, version: 6.1.7601.18517, time stamp: 0x53aa2e07
    Exception code: 0xc0000005
    Fault offset: 0x000000000019e877
    Faulting process id: 0x9f4
    Faulting application start time: 0x01cfd7bffecce0ac
    Faulting application path: D:\Program Files (x86)\Steam\steamapps\common\Construct2\Construct2-Win64\Construct2.exe
    Faulting module path: C:\Windows\system32\SHELL32.dll[/code:tymktegh]
    [b]Steps to Reproduce Bug[/b]
    [ul]
        [li] Step 1 - Redirect your My Documents folder to a mapped network share.  In my situation the W drive which maps to my NAS.
        [/li][li] Step 2 - Logoff and log back in again to Windows.
        [/li][li] Step 3 - Launch Construct 2 and go to "Open Project" on the start page or File > Open.[/li][/ul]
    [b]Observed Result[/b]
    The application crashes after step 3 above.
        
    [b]Expected Result[/b]
    Construct 2 should not crash and instead open up the open file dialog as it normally would.
       
    [b]Operating System and Service Pack[/b]
    Windows 7 SP1 x64
        
    [b]Construct 2 Version ID[/b]
    Release 178 (64-bit/Steam)
    
    [b]Troubleshooting Performed[/b]
    This issue is related to folder redirection of the My Documents folder to a network share.  Possibly related to a custom folder (or folder namespace?) in the Open dialog's navigation pane titled "Construct 2 game creator" which points to <My Documents>\Steam Cloud\<username>\Construct 2 Free.
    
    [b]Workarounds[/b]
    [ul]
        [li] Disconnect the W drive (redirected My Documents).
        [/li][li] Redirect My Documents back to a local path and logoff and log back on again.[/li][/ul]
    Neither of the workarounds are ideal.  Especially in a networked environment with centralized storage.  I'm hopeful this issue can be addressed.
  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • How exactly are you performing step 1? What are you doing to redirect the "My Documents" folder to a network share?

  • Right click your My Documents folder and choose properties. There should be a location tab. On the location tab you can modify the location of My Documents. I have my pointing to the W drive which is mapped to a network share.

  • I can't reproduce it. I tried it on Windows 8.1 with a network drive on W: pointing to a remote machine and signing out and in again. Construct 2 seemed to work just fine. The only reason it should access 'My documents' is to look for a license, and I tried it with a license on the mapped drive as well and it still found it and loaded it OK.

    Generally the main problem C2 crashes on 'File - New' or 'File - Open' is due to buggy graphics drivers, since that's the first point it creates an OpenGL context. Are your graphics drivers up to date?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)