Nothing in canevas

  • Problem Description

    I can preview my game, I can export it.

    The game works on clay.io. I had to export for Chrome Web Store the html5 and copy html5 exported files on Chrome files (maybe you can tell me why lol), else clay.io didn't recognize the package as an update from previous upload. But it works well. Not incredible fps on tab and phone but no real problem.

    When I compile my game for Android with Intel Crosswalk or CocoonJS, if I install and launch the apk, there is nothing in the canevas !

    I tried on a tab with Android 4.2.2 and on a phone with Android 4.1.1.

    Attach a Capx

    I can't but, here is a screenshot : http://ovh.to/Y5AdtyY

    and here is a log file : http://ovh.to/wgc3CE

    Description of Capx

    This screenshot shows you what are my project properties, the loading of the game and the plugins used.

    Steps to Reproduce Bug

    • Export with any Android exporter
    • Install the APK on phone or tab
    • Launch

    Observed Result

    Black Screen

    Expected Result

    Maybe.. loading ?

    Affected Browsers

    • Chrome: NO
    • FireFox: NO
    • Internet Explorer: NO

    Operating System and Service Pack

    VirtualBox with Windos7 sp1

    Construct 2 Version ID

    178

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Closing, I'm afraid there is nothing we can do if you do not provide us with a minimal .capx that reproduces the problem. As it stands, I assume one of the third party plugins you are using causes the problem.

  • I tried removing clay.io plugins : same thing.

  • I'm afraid there is still nothing we can do unless you meet the requirements of the bug report guidelines.

  • Found the problem : this dear CocoonJS plugin...

    Whe should stop using this thing. Too much problems.

    Thx Ashley

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)