Not loading game

0 favourites
  • 13 posts
From the Asset Store
2D fighting template based in the game that defined the fighting games genre.
  • In the class I'm teaching, I tried to Run Layout, and it isn't letting me. There are 15 computers hooked up to the lab using WINXP.

    Students have a student account which doesn't let them have admin access, and instructors (me) have admin access. I can run the game fine on MY admin computer, but the students cannot on theirs.

    They get a 'Unable to starrt HTTP Server for Preview.' Then, I press the 'reconfigure', and it becomes a blank box with a error message.

    I tried to log into a student computer under the admin, but this message popped up.


    Construct 2 Check failure


    Check failure! This is probably a bug:

    After creating request queue, handle is NULL

    Condition: hRequestQueue != NULL

    File: HttpFileServer.cpp

    Line: 47

    Function: void __thiscall HttpFileServer::Start(const class std::basic_string<wchar_t,struct std::char_traits<wchar_t>,class std::allocator<wchar_t> > &,int)

    Build: release 79.4 (32-bit) checked

    Component: HTML5 exporter

    (Last Win32 error: 0)

    You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.


    Abort   Retry   Ignore   


  • So I managed to get the admin to turn off the firewalls for the student computers. That didn't work.

    The students are on a limited WinXP account.

    Although the play button doesn't work, I'm trying a work around where they just export it and run it from dropbox to test their game.

  • Try to have a preview over LAN from the admin computer (check with your network admins).

    It can be tedious, but at least students could preview a project (even if not theirs) "quicker".

    Eventually try to see with the network admins if they couldn't have a local webserver (on the students computers) set up for each account.

    This could help them previewing easier.

  • Hmm, that's annoying. What service pack of XP are you using? The HTTP server won't work at all unless SP2 or newer is installed, but I'd recommend SP3 anyway, it's a free update.

    I thought the HTTP server should work OK on limited user accounts. Perhaps some other permission has been set on the computers that blocks it? HTML5 games will only preview properly on a HTTP server, and Construct 2 must have permission to start it in order to preview the games.

    A workaround is you can try setting 'Preview Mode' to 'File' in project properties, which skips using the HTTP server. However this is deprecated and will prompt you every time because we want to remove it - as I said, games only work properly on a HTTP server, so using this method will mean lots of things don't work (sound won't work, Chrome might not be able to run the games at all, you may get errors/freezes half way through the game, etc).

  • The students computers are WinXP SP2.

    This is another error message that files off. "Error during export : Unable to start HTTP server on 'localhost' port 50000 (1114)

    I changed the Preview mode to 'File', and the game doesn't even load.

    I found a work around by exporting the project, and having them run it via dropbox. They would just have to export the project every time to run it. Luckily, they're not writing code - only switching artwork around.

  • Also, another bug I found - very minor - involving the jquery-1.7.1.min.

    Of the 12 computers, 3 of them failed to export because jquery-1.7.1.min wasn't created properly. It hung at jquery-1.7.1.min.temp. I fixed it by copying that file over from other exported projects, and it worked fine.

  • Oh man. New error.

    Click on one of the enemy types on the left side. (I clicked on shield type). Double click on it to open up the image editor. Open a png file to replace the enemy type's image. Crashes. - the error - the png file - the construct file

    Also, for some reason, Construct 2 isn't loading their image.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • The first thing I would recommend is updating all the computers to SP3. It's a free update and may fix some of the issues.

    The second thing is you should update all the computer's graphics card drivers. Out of date drivers is the #1 problem causing crashes and glitches in Construct 2. The error you linked to (referencing atioglxx.dll) is the driver for the ATI graphics card that has crashed, so there is nothing we can do to fix it from Construct 2, it's ATI's fault. In our system requirements we note you must have the latest graphics card drivers and we've blogged about the issue and why it is largely out of our hands. ATI make crappy, broken drivers and it makes our software look like it's broken :-

    After you have fixed both those points things should work a lot more smoothly. I know it's a pain managing a whole room of computers but I'm afraid if you don't keep them up to date then it's difficult to guarantee newer software is going to work properly. FYI service pack 3 was released in 2008, nearly 4 years ago, and SP2 was released in 2004, so is now nearly eight years old, which is a very long time in technology.

  • When I read the error code, I figured it was a graphic card issue. I'm going to see if I can ninja into the lab and upgrade all the comps to SP3.

    On my sexy Crysis-on-max-settings rig at home, the files don't seem to be an issue. So it has to be the lab's old computers.

    Thanks for the reply! It's slowly melting away my nervous breakdown. :)

    EDIT : Once I get that part working out, any suggestions on how to get the preview run working on limited user privilages? Firewalls? I wish I knew more about that side of technology.

  • In fact, when the student machines will be able to launch a local http server (something hopefuly SP3 should enable), there shouldn't be issues anymore.

    The local server part is handled by C2.

    If you still have troubles, you can try a "workaround" installing a software like wamp on each machine.

    It's a local server too, and what you will need will be to export the projects to the www folder set in wamp's configuration.

    Then from the browser you will go to localhost (or and you should be able to browse through the exported projects and execute them.

    It removes the "upload to dropbox" from your previous workaround.

    It's still tedious, but it can help.

  • The error you posted mentioned error 1114, which I looked up and is "A dynamic link library (DLL) initialization routine failed". I think perhaps the HTTP server is not supported on SP2 after all. Hopefully upgrading to SP3 should fix it. To be honest we've never officially tested Construct 2 on XP SP2, it's just the technical documentation we've read indicates it should work on SP2, but there's nothing like real world testing. If upgrading to SP3 works, I'll revise the manual system requirements to say SP3. So let me know how it goes! I hope the next session goes a bit better :-\

  • I'm having the same problem loading games on my Laptop. (error atioglxx.dll) It's a Toshiba Satelite with XP SP 2 Home edition.

    My desktop computer has XP Pro SP2, and it doesn't have any problems with loading games in Construct 2. My desktop uses an Nvidia Gforce 9800gt. I made a file with Construct 2 r99 on my desktop (with no problems) and sent it to my Laptop, and on the laptop it will not even open. I've tried updating my ATI drivers, to no avail, thanks to ATI's lack of legacy driver support. Built in GPU is an ATI Radeon xpress 200m. I'd be curious to know if SP3 fixes the problem, or if it's purely an ATI-driver issue.

  • Afrit - we no longer officially support XP SP2. You should *definitely* upgrade to XP SP3 which we do support. Out of curiosity, why haven't you installed it already? It was released years ago and is a free upgrade.

    atioglxx.dll is your graphics driver. Updating it may help, but I would install SP3 first then update the driver, since the latest driver may also require SP3.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)