[node-webkit] Seams around texture borders (rev)

0 favourites
  • 2 posts
From the Asset Store
High quality sound effect pack, in the following categories: Dark, Mystical, Peaceful
  • Link to .capx file (required!):


    Steps to reproduce:

    1. Create tiles using sprite method.

    2. Run the .capx within construct 2 (works fine).

    3. Export it using node-webkit (now shows seams around the textures borders (observable in full screen)).

    Observed result:

    Seams around texture borders.

    Expected result:

    No display artifacts, just the texture.

    Operating system & service pack:

    Windows 7, service pack 1

    Construct 2 version:

    r126, r127 (same bug)

    Yes Andreyin, in this little example (the .capx for the .exe file in the previous post) the textures are created using the power-of-two size format (though that's not the texture size I'm using in my game levels, but the same bug appears whatever texture size I use).

    Sorry for creating and uploading the .exe file earlier, my bad :P

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Closing: in computer graphics, you cannot guarantee seamless display of adjacent images unless you use both pixel rounding and letterbox integer scale (normal letterbox scale will result in floating point scale levels, which can cause seams). I'm not sure why Chrome manages to display it without seams, but you still can't rely on it to be seamless on all systems without those settings. I noticed Internet Explorer seams in the browser too without those settings.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)