Multiplayer timeout (Attempting to establish connection to host...)

  • Hello,

    I am trying to use multiplayer. However, the logs just say "attempting to establish connection to host..." but then it just kicks for timeout.

    Joining as host, however, does work perfectly.

    I thought it was my code's fault so I tried the default "Multiplayer game example" game. The same problem occurred.

    Also, my VPN sent me a message when I connected as a peer saying that this website might compromise your data. This made me think that this bug could have something to do with firewall or antivirus.

    I suggest you make an alternative way of multiplayer (e.g. using your server as host) because for now this peer-to-peer idea or websocket do not feel very stable.

    If this matters, I am using a public network but I tried to connect via VPN and it still did not work.

    I thought this might be scirra signaling server so I purchased and set up my own, but that did not help at all.

    Another thing, when a peer tries to join, the host gets a popup with the following error:

    JavaScript error!
    Object doesn't support property or method 'createDataChannel' 

    mywebsite.com/c2mp-peer.js, line 192 (col 4) [/p] This may be a bug in Construct 2 or a third party plugin behavior - please report it to the developer following the bug report guidelines. Errors will be logged to the console. [/p]

    And the console error I get is:

    SCRIPT438: Object doesn't support property or method 'createDataChannel'

    Please fix this or tell me the solution ASAP.

    Thanks.

  • Please see the bug report guidelines for posting in this forum - we need more details like specifically which browser/OS versions are affected, steps to reproduce, etc. Also in general whether or not connections can be established depends on your network configuration.

  • Could not find the guidelines. Also, I figured this only happens on computers with no admin rights. I also think it can be because of firewall or something.

  • Could not find the guidelines. Also, I figured this only happens on computers with no admin rights. I also think it can be because of firewall or something.

    construct.net/en/forum/construct-2/bugs-21/must-read-first-bug-report-req-39300

    The sticky topic on top in the bugs forum that is named:

    ***MUST READ FIRST!*** Bug report REQUIREMENTS

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • It doesn't look there are any guidelines over there though.

  • Ha right, this hasn't been corrected yet.

    Here is a template :

    ## Problem description

    <!-- Enter a concise description of your problem here -->

    ## Attach a .capx

    <!-- A minimal Construct 2 project (.capx) is required to be attached. Your issue will likely be closed without investigation if you don't provide one. Please see the guidelines -->

    ## Steps to reproduce

    <!-- There is no need to explain how you made the attached project. Just explain what to do to with it to observe the issue. -->

    1.

    2.

    3.

    ## Observed result

    <!-- What do you see happen? -->

    ## Expected result

    <!-- What did you expect to happen instead? -->

    ## Affected browsers

    * Chrome: yes/no

    * Firefox: yes/no

    * Edge: yes/no

    * Safari: yes/no

    ## System details

    <!-- The OS and hardware specifications of your computer where you are encountering the issue -->

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)