Multiplayer plugin is not working

0 favourites
  • 5 posts
From the Asset Store
2D fighting template based in the game that defined the fighting games genre.
  • Problem Description

    I'm writing a game with a server that sends questions to all connected clients, that then respond. The server program is working fine, but the client is not connecting. I have isolated the problem to the fact that it will not log in. I then made a new project with three layouts. The first layout connects to the signaling server, and then enables a button, which works fine. The button goes to the second layout, which logs in with the required alias, which is supposed to activate a second button, but the button never activates. I've tried exporting it to node-webkit, html5, android, i've tried changing the alias, but it never logs in.

    Description of Capx

    The capx has three layouts, and I describe their function above

    Steps to Reproduce Bug

    • Launch game
    • Click okay when enabled to attempt to login
    • Confirm button moved. It is in a different place to distinguish the first layout from the second

    Observed Result

    On the second layout, the button never activates

    Expected Result

    The button should activate, being caused by the Multiplayer plugin logging in.

    Affected Browsers

    • Chrome
    • Opera
    • Node Webkit
    • Android

    Operating System and Service Pack

    Windows 8.1

    Construct 2 Version ID


  • [quote:3p3imowe]Attach a Capx

    ____ Upload a Capx to this post ____

    Was just above description of capx.

    You need to attach a capx file proving it isn't working else Ashley will close this as he can't reproduce it.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Another requirement is to test on latest release, which is currently r206 stable, just in case it was a bug that's been fixed.

  • In one of the recent versions there was a bug fix for firefox clients connection problems.

    Perhaps this is related.

  • Closed, see the bug report requirements

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)